Forum Stats

  • 3,825,482 Users
  • 2,260,519 Discussions
  • 7,896,547 Comments

Discussions

OEPE 12.2.1.6 does not support WebLogic server 12.2.1.3 ?

jgremmen
jgremmen Member Posts: 2
edited Mar 22, 2018 3:43AM in Enterprise Pack for Eclipse

I installed OEPE on serveral eclipse versions (neon, oxygen) and also downloaded the packaged distribution from this site: Oracle Enterprise Pack for Eclipse (12.2.1.6) .

If I want to create a new server instance in eclipse and specify the WebLogic home directory, it says:

"The path "D:\Oracle\Middleware-12.2.1.3.0\wlserver" does not contain a valid WebLogic Server install or the installed version is not supported."

I get the same error message over and over again. However, If I specify the WebLogic home directory of an older version it has no problem with it. The WebLogic server itself is working just fine if I start a domain by using the batch scripts.

So, why is WebLogic version 12.2.1.3 not supported? Is there a trick to get it running?

jgremmenuser89552691458114

Answers

  • Kosta-Oracle
    Kosta-Oracle Member Posts: 461
    edited Sep 29, 2017 4:02PM

    You are correct in that WLS 12.2.1.3 is not yet supported by OEPE. We expect to extend support to this version later this year.

    jgremmen
  • 1458114
    1458114 Member Posts: 2
    edited Oct 10, 2017 8:11AM

    Hi @Kosta-Oracle,

    is there a way to obtain a pre-release version of OEPE? Something like a beta-repository for eclipse? I could not find any information about it on the Oracle sites.

    Thanks,

    Julian

  • user8955269
    user8955269 Member Posts: 9 Blue Ribbon
    edited Dec 13, 2017 2:48AM

    You could try to use OEPE 12.2.1.3.1 (Eclipse NEON) This supports my WLS 12.2.1.3

    1458114
  • user4646063
    user4646063 Member Posts: 2
    edited Jan 11, 2018 10:50AM

    It seems like this is still an issue.


    I am using the newest version of Spring Tool Suite (3.9.2)  which is based on Eclipse 4.7.2.

    When trying to add a new WLS 12.2.1.3.0 I get the error:

    "The path "C:\Oracle\Middleware12213\wlserver" does not contain a valid WebLogic Server install or the installed version is not supported."


    Trying to update Spring Tool Suite with the newest "'Oracle WebLogic Server Tools" using download.oracle.com/otn_software/oepe/12.2.1.6/neon/repository/

    was not succesful.

    Error message was:  Cannot complete the request. "Oracle WebLogic Server Tools" will be ignored because a newer version is already installed.

    So still no solution?

    Regards Jesper

    user8955269
  • 1458114
    1458114 Member Posts: 2
    edited Jan 19, 2018 6:46AM

    Yep, still an issue with 12.2.1.6 and no answer, patch or any kind of reaction whatsoever from Oracle. Thanks for that.

    @user8955269's solution kind of works, though. At least I was able to add a 12.2.1.3 Runtime Environment. Had some eclipse hangups since then, so this workaround seems not very stable to me. One should at least expect various unknown behaviours. If anyone succeeds, please let me know.

    This is all very disappointing, At least a small patch for OEPE to enable us to set up an Execution Environment with a 12.2.1.3 WebLogic as is - regardless of any known/unknown incompatibilities - would not render the whole project useless as it is now.

    user8955269
  • SVF
    SVF Member Posts: 1
    edited Mar 9, 2018 7:58AM

    Hi,

    Any news about the upgrade?

    We've to use the last version of the WLS because of license limitations, but Oracle doesn't provide tool for it - it's a really strange situation, istn't it?

    Oracle's behavior enforces us to start finding alternate ways and we're starting to evaluate how can we migrate from the WLS. Of course,  not only because of the OEPE, but it can become a last drop.

  • Danny.Ju-Oracle
    Danny.Ju-Oracle Member Posts: 97 Employee
    edited Mar 9, 2018 8:41AM

    Hi, apologize for the delay. We are busy working on finishing the verification process while I am speaking. The release should be available soon.

  • Danny.Ju-Oracle
    Danny.Ju-Oracle Member Posts: 97 Employee
    edited Mar 20, 2018 10:41PM

    OEPE 12.2.1.7 has just been released, with support of WLS 12.2.1.3. Please download  from OTN.

  • user8955269
    user8955269 Member Posts: 9 Blue Ribbon
    edited Mar 22, 2018 3:43AM

    Thanks for informing, this works now :-)

This discussion has been closed.