Forum Stats

  • 3,781,628 Users
  • 2,254,532 Discussions
  • 7,879,769 Comments

Discussions

Install Oracle 12.2 on CentOS 7 fails

Panagiotis
Panagiotis Member Posts: 10
edited Dec 7, 2017 3:00AM in Database Installation

Hi everyone,

  we are trying to install Oracle Database ver. 12.2 on a CentOS 7 server but towards the end of the installation it prompts an error message about port 5500 is not free. The server is running as a VM on an ESXi cluster and has been vanilla installed and upto date with the latest updates. We have searched using "netstat -an | grep 5500" but this port is not been used. Has anyone had any issue like this one? Any hints?

Best regards and thank you in advance,

Panos.

Tagged:

Best Answer

Answers

  • EdStevens
    EdStevens Member Posts: 28,604 Gold Crown
    edited Sep 28, 2017 2:44PM
    Panagiotis wrote:Hi everyone, we are trying to install Oracle Database ver. 12.2 on a CentOS 7 server but towards the end of the installation it prompts an error message about port 5500 is not free. The server is running as a VM on an ESXi cluster and has been vanilla installed and upto date with the latest updates. We have searched using "netstat -an | grep 5500" but this port is not been used. Has anyone had any issue like this one? Any hints?Best regards and thank you in advance,Panos.

    First off, why are you installing on an OS for which Oracle is not certified?  Why not use Oracle Linux, which

    - only charges for support, not operating license

    - is certified for use with Oracle database

    - is from the same family as CentOS, so near zero learning curve.

    That said, it's been a while since I've installed v12, but I am upgrading from 11.2 to 12.1 on a regular basis.  When you installed (actually, when you created a db) was there a screen asking about port for EM Express?  If so, what did you select?  My guess is that the default was 5500 and you accepted it.  It is further my semi-educated guess that the conflict was not with some process actively using 5500, but oracle checking against a list it keeps for itself.  Look for a file 'portlist.ini'.

  • Dude!
    Dude! Member Posts: 22,826 Black Diamond
    edited Sep 28, 2017 4:06PM

    Maybe firewall?

  • handat
    handat Member Posts: 4,688 Gold Crown
    edited Sep 28, 2017 8:05PM

    Is selinux enabled in strict mode?

  • Panagiotis
    Panagiotis Member Posts: 10
    edited Sep 30, 2017 3:06AM

    Hi @Dude! thanks for your feedback but i have switched off the firewall for the whole Oracle Database installation in order to avoid beforehand these issues (if caused by the firewall).

    Best regards,

    Panos.

  • Panagiotis
    Panagiotis Member Posts: 10
    edited Sep 30, 2017 3:07AM

    Hi @handat thank you also for your feedback but i have turned SELinux to permissive before start installing the Oracle Database.

    Best regards,

    Panos.

  • Panagiotis
    Panagiotis Member Posts: 10
    edited Sep 30, 2017 3:13AM

    Hi @EdStevens thank you also so much for your feedback but the situation is much more "ugly" than i originally thought! It fails to install the the actual database! It just installs the DB engine and all the database software. Your guess about the Oracle Database installation is correct...i am choosing the "Typical" installation type which asks for the bare minimum of settings. I have tried another small experiment though...i had a Virtualbox installation sitting at my machine so i went ahead and installed CentOS 7 and Oracle 12c there and everything went smooth and the database has been installed without any problem! Both CentOS 7environments (ESXi and Virtualbox) are exactly the same because i have installed these from scratch.

    Is there anything else that i am missing?

    Best regards,

    Panos.

  • Anderson Gonçalo
    Anderson Gonçalo Member Posts: 9 Blue Ribbon
    edited Oct 2, 2017 8:43AM Accepted Answer

    Hi @Panagiotis,

    Did you add the correct hostname and ip address in /etc/hosts?

  • EdStevens
    EdStevens Member Posts: 28,604 Gold Crown
    edited Oct 2, 2017 9:42AM
    Panagiotis wrote:Hi EdStevens thank you also so much for your feedback but the situation is much more "ugly" than i originally thought! It fails to install the the actual database! It just installs the DB engine and all the database software. Your guess about the Oracle Database installation is correct...i am choosing the "Typical" installation type which asks for the bare minimum of settings. I have tried another small experiment though...i had a Virtualbox installation sitting at my machine so i went ahead and installed CentOS 7 and Oracle 12c there and everything went smooth and the database has been installed without any problem! Both CentOS 7environments (ESXi and Virtualbox) are exactly the same because i have installed these from scratch.Is there anything else that i am missing?Best regards,Panos.

    Just a correction in your terminology, and possibly - as a result - your understanding of some fundamentals:

    Databases are not "installed".  They are "created", after having installed the software.

    No, your ESXi and VBox are NOT "exactly the same".  If they were exactly the same, you'd get exactly the same results.

    You did not answer my question about why you are using a non-certified OS.  That is most likely not the cause of your current issue, but if you persist in using a non-certified OS you will - at the least - not have support from Oracle.

  • B Dave
    B Dave Member Posts: 97 Blue Ribbon
    edited Oct 6, 2017 12:00AM

    If port has not been used then try disabling selinux/firewall.

    Also Ed is right. Install on non-certified OS on your own risk.

    Resolve Issues of Installing on non-certified OS at trial and error basis.

    Regards,

    B Dave

  • Panagiotis
    Panagiotis Member Posts: 10
    edited Dec 7, 2017 3:00AM

    Hi @EdStevens,

       my apologies for the late reply. My mistake was not updating 'properly' my /etc/hosts file but we have switched to Oracle Linux in order to be more 'safe' in a sense of using a certified linux distribution.

    Best regards,

    Panos.

This discussion has been closed.