Forum Stats

  • 3,759,890 Users
  • 2,251,611 Discussions
  • 7,870,857 Comments

Discussions

Oracle SQL Developer - Can't connect to SQL Server Database

cd6ffb1b-fb0f-401a-a99d-dd1776dc7b5e
edited Jan 27, 2018 2:37PM in Designer

SQL Developer 4.0.3.  I am trying to connect to an SQL Server database from SQL Developer.  I have gone to Third Party JDBC Drivers and added a jtds-1.2.8.jar file path.  I get the SQL Server tab in the Properties window for the connection.  I have filled in the correct hostname, trying alternatively host, host.domain, and IP address, and the correct port number.  When I try to Retrieve database, I get the following error message:  Status : -I/O Error : DB server closed connection.  To troubleshoot, I have also tried to add parameters to the port number.  (e.g., 1433;instance=...).  I have also tried adding /instance_name and \instance_name to the hostname, to no effect.  (Apparently, the host has a default SQL Server instance so the instance name is unnecessary.)  I can successfully connect to the SQL Server database using Toad for SQL Server, and through a database link using an Oracle gateway for SQL Server, and via .udl file (OLE DB Connection), so the SQL Server database seems to be functioning fairly normally.  At this point I think I have the basics down for setting up the connection.  One thing that looks weird to me:  On the connection details list for the connection, I see [email protected]:1433/null.  Could the /null be causing the problem?  My questions: 1) Has anyone been able to use this successfully?  2) If so, is the SQL Server database on the machine where SQL Developer is running? 3) Are there an known Oracle bugs or configuration arcana? 4) Are there any known SQL Server configuration requirements to support this type of access?  5) Any other suggestions that I might try?

This discussion has been closed.