Forum Stats

  • 3,875,109 Users
  • 2,266,806 Discussions


Java Mission Control - Windows7(32bit) - hsperfdata_<name> : How to stop JMC installation locking th

Westy_007+half Member Posts: 1
edited Feb 17, 2018 5:35PM in Java Mission Control

Hello, I hope you're sitting comfortably; I will begin.

1. Have tried all week, on and off, to install Android Studio; the **** thing fails to launch: "does not point to a valid JVM installation."

2. So un-installed Android Studio and Java, followed by a quick spring clean around the registry area...

3. Java 32bit Developer Kit version 8 update 162 was duly installed, but the re-installed Android Studio still failed to launch. "Mission Control we have a problem!" [that's me speaking :-(]

4. The hsperfdata_<user> folder had indeed been locked, as the launch error message suggested. [see attached]  So I unlocked it, but didn't go inside - honest...

5. Another un-install, re-install trip to the launch pad failed to ignite Mission Control. The hsperfdata_<user> folder had been re-locked! The folder's security properties had reverted to 'special'!

6. Whilst I was tinkering under the bonnet - that's hood to our American friends - changing the inherited permissions back; some bright spark (genius) at said to also look into the jmc.ini file. I don't have a jmc.ini file! Well, not where he said it should be - JAVA_HOME/lib/mission control/jmc.ini

7. Another few trips to the launch pad followed, using various combinations of permissions with and without virus protection/firewall. Still no joy.

This concludes my sorry tale, to date. But forever hopeful that some kind sole will help to get Mission Control off the ground before I start running.



Message was added by: 3641788 Saturday 17th Feb. @ 22:25 GMT The latest attempted installment log is attached; hopefully this will give a clue as to why there is no jmc.ini file in the mission control folder. HTH, John

This discussion has been closed.