developers

    Forum Stats

  • 3,873,861 Users
  • 2,266,623 Discussions
  • 7,911,645 Comments

Discussions

Which version of java mission control to analyze JFR?

User_OU04L
User_OU04L Member Posts: 3 Employee
edited Apr 22, 2018 3:26AM in Java Mission Control

Hi All,

i want to analyze JFR , could someone please suggest which version of java mission control i should use. where i could analyze JFR using ECIDs...

thanks in advance

User_OU04L

Best Answer

  • Hirt-Oracle
    Hirt-Oracle Member Posts: 268
    edited Apr 21, 2018 2:05AM Answer ✓

    Hi!

    That depends on which version of the JVM you are running WLS on - you would normally use the version of JMC shipped with an Oracle JDK of the same version. To install the WLS plug-ins, you simply go to Help | Install New Software... and select the WebLogic plug-in. Note that you can also use JMC 6, shipped with JDK 9 and JDK 10, to look at recordings from the previous versions.

    As soon as we have open sourced JMC, you will be able to build and use JMC 7 to analyse the recordings from 7u40 and above.

    Kind regards,

    Marcus

    User_OU04L

Answers

  • Hirt-Oracle
    Hirt-Oracle Member Posts: 268
    edited Apr 21, 2018 2:05AM Answer ✓

    Hi!

    That depends on which version of the JVM you are running WLS on - you would normally use the version of JMC shipped with an Oracle JDK of the same version. To install the WLS plug-ins, you simply go to Help | Install New Software... and select the WebLogic plug-in. Note that you can also use JMC 6, shipped with JDK 9 and JDK 10, to look at recordings from the previous versions.

    As soon as we have open sourced JMC, you will be able to build and use JMC 7 to analyse the recordings from 7u40 and above.

    Kind regards,

    Marcus

    User_OU04L
  • User_OU04L
    User_OU04L Member Posts: 3 Employee
    edited Apr 22, 2018 3:26AM

    Thanks a lot for your help. it helped.

This discussion has been closed.
developers