Forum Stats

  • 3,760,355 Users
  • 2,251,692 Discussions
  • 7,871,075 Comments

Discussions

Why i can't start sqlcl 18.2.0?

3629179
3629179 Member Posts: 3
edited Aug 24, 2018 11:50AM in SQLcl

Trying to start sqlcl 18.2.0 with jdk 1.8.0_181 or jdk 1.8.0_161 but id doesn't work. The previous version of sqlcl i used was 17.4.0 and was working fine. I am using oracle client version 11.2.0.4.0.

Error Message = Could not initialize class oracle.jdbc.OracleDriver

Answers

  • Glen Conway
    Glen Conway Member Posts: 859 Gold Badge
    edited Aug 24, 2018 11:50AM

    Sounds like there is an incompatibility between the JDBC driver and the version of Java you are running.  Are you sure SQLcl is not picking up a Java 9 jre instead and trying to use the 11.2 client JDBC driver?

    Here is a post I found that discusses how SQLcl finds the jre:   

    Hope this helps!