Forum Stats

  • 3,769,507 Users
  • 2,252,970 Discussions
  • 7,875,064 Comments

Discussions

Problems installing ODTwithODAC122010 error - Oracle.DataAccess.Client.OracleClientFactory?

3788119
3788119 Member Posts: 1
edited Sep 18, 2018 10:37AM in Downloads Issues

Hello All,

I hope I have posted to the right group!

I have an error with VS2017 running on Windows 10 x64 using Oracle 12.2.0.1.0 installation of Oracle.  The issue is when I try and connect to an Oracle Server using Tools/Server and create a new connection the following happens,

a)
I can't even connect using the managed driver, this comes up with the following error.

     'Network Naming: No LDAP server detected or configured.'

b)
When it comes to using the unmanaged driver, I get the error message...

    

          The Type initialiser for 'Oracle.DataAccess.Client.OracleClientFactory' threw an exception.

I have tried installing vs and re-installing oracle several times with the same result.

I have two installations of ODP which are required.

The first is 11.2.0 is because we have a 10g Oracle Server.  The second which is 12.2.0 is to work with 12.2.0.

These are installed as:

The base directory I have installed these drivers into

     c:\Oracle\11.2.0

     c:\Oracle\12.2.0

Other observations:

-  I have imported TNSNAMES.ora and SQLNAmes.ora into the into Network Admin.
on both installations.

-  The TNS names can be successfully imported into the Oracle Managed Connection and shows in the dropdown list.

-  For the Oracle Unmanaged Client, although it can see and import the TNSNames from file, it does not show this
in the dropdown list.

Can anyone please help?

Regards,

Richard

This discussion has been closed.