On January 27th, this site will be read-only as we migrate to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,889,584 Users
  • 2,269,760 Discussions
  • 7,916,784 Comments

Discussions

FileNotFoundException: 00000007.jdb

3081763
3081763 Member Posts: 1
edited Nov 11, 2018 12:29PM in Berkeley DB Java Edition
<span class="line" lang="plaintext">Exception in thread "AWT-EventQueue-0" com.sleepycat.je.EnvironmentFailureException: (JE 6.4.25) /data/projects/Maeanderungen/workspaces_kunstradio/Maeanderungen-octo-13.mllt last LSN=0x7/0x0 LOG_INTEGRITY: Log information is incorrect, problem is likely persistent. Environment is invalid and must be closed.<br/></span><span class="line" lang="plaintext">     at com.sleepycat.je.recovery.RecoveryManager.traceAndThrowException(RecoveryManager.java:3226)<br/></span><span class="line" lang="plaintext">     at com.sleepycat.je.recovery.RecoveryManager.redoLNs(RecoveryManager.java:2052)\<br/></span><span class="line" lang="plaintext">...<br/></span><span class="line" lang="plaintext">Caused by: com.sleepycat.je.EnvironmentFailureException: (JE 6.4.25) /data/projects/Maeanderungen/workspaces_kunstradio/Maeanderungen-octo-13.mllt java.io.FileNotFoundException: /data/projects/Maeanderungen/workspaces_kunstradio/Maeanderungen-octo-13.mllt/00000007.jdb (No such file or directory) LOG_FILE_NOT_FOUND: Log file missing, log is likely invalid. Environment is invalid and must be closed.</span><br/><span class="line" lang="plaintext">     at com.sleepycat.je.log.FileReader.readNextEntry(FileReader.java:278)<br/></span><span class="line" lang="plaintext">     at com.sleepycat.je.recovery.RecoveryManager.redoLNs(RecoveryManager.java:2000)<br/></span><span class="line" lang="plaintext">     ... 55 more<br/></span><span class="line" lang="plaintext">Caused by: java.io.FileNotFoundException: /data/projects/Maeanderungen/workspaces_kunstradio/Maeanderungen-octo-13.mllt/00000007.jdb (No such file or directory)</span>   <span class="line" lang="plaintext">Hello,<br/><br/>I have a severe problem; it seems BDB corrupted one of my databases; when I try to open it I get this:<br/><br/>(removing block-quote as web editor seems broken; can people please use GF-MD in 2018?)<br/><br/></span>

The db was created with 5.0.104 (as the application is Java 6 compatible); but I now also tried opening it with 6.4.25 (see log above) and 7.4.5, always the same error. I'm using nothing fancy, ACID is configured, then only `db.get`, `db.put` and `txn.commit`. So 99% certainly this is a bug in BDB. The directory only contains files `00000008.jdb` through `0000000f.jdb`.

Is there any chance I can recover this database?

Best, ..h.h..