Forum Stats

  • 3,770,593 Users
  • 2,253,137 Discussions
  • 7,875,502 Comments

Discussions

windows container install oracle db

3570408
3570408 Member Posts: 1
edited Jul 18, 2019 5:13AM in Containers

I have been struggling with this for a couple of days

I have Oracle setup installer and response files ready, I run the setup command with my response file from an elevated cmd window, no problems found, oracledb installs according to my reponsefile

CMD command
setup -silent -responsefile d:\temp\database\response\db.rsp -skipPrereqs -noconfig -waitForCompletion

But even with silent switch the Oracle Universal Installer and some other configuration screens still popup, that will not work when installing from an image or within a container itself
(see picture attached)

oracle_image_install

When try to replicate using my dockerfile or an error or nothing happens

Docker file
#Sample Dockerfile

#Indicates that the windowsservercore image will be used as the base image.
FROM microsoft/windowsservercore

#Create the working folder
RUN mkdir c:\temp\database

#Copy Oracle installers and response file to the working directory previously created
COPY database /temp/database

#Run the command
RUN Powershell.exe Start-Process -FilePath ‘C:\temp\database\setup.exe’ -argumentlist ‘-responsefile c:\temp\database\response\db.rsp’, ‘silent’ -wait

Once ready I run on an elevated powershell Window

PS D:\docker\dockerfiles> docker image build -t 2016oracle -f dockerfile .

As I said even that the build might finish successfully and without errors the application it is not installed or the container run for a moment and then exits few seconds later

Answers

  • User_3TUKA
    User_3TUKA Member Posts: 5 Red Ribbon
    edited Apr 5, 2019 5:58AM

    any news at this?, I had the same issue.

  • Sean Schneeweiss
    Sean Schneeweiss Member Posts: 5
    edited Jul 18, 2019 5:13AM

    To start the installation of i.e. Oracle database I'm using this command:

    # escape=`FROM mcr.microsoft.com/windows/servercore:ltsc2016SHELL ["powershell", "-Command", "$ErrorActionPreference = 'Stop'; $ProgressPreference = 'SilentlyContinue';"]WORKDIR c:\\tempCOPY WINDOWS.X64_180000_db_home.zip oracle.zipRUN Expand-Archive oracle.zip -DestinationPath oracle; `    Remove-Item -Force oracle.zip;ENV ORACLE_HOME=C:\temp\oracleCOPY responsefile.rsp db.rspRUN Start-Process $env:ORACLE_HOME\setup.exe `    -ArgumentList '-silent', '-nowait', '-waitforcompletion', `    '-ignorePrereqFailure', `    '-responseFile', 'C:\temp\db.rsp' `    -NoNewWindow -Wait;

    Maybe the parameter NoNewWindow and Wait will help.

    Good luck.