Forum Stats

  • 3,825,267 Users
  • 2,260,491 Discussions
  • 7,896,472 Comments

Discussions

Invalid Oracle Home User Password during Oracle 12c DB creation using DBCA

Muthuramalingam.K
Muthuramalingam.K Member Posts: 55 Blue Ribbon
edited Nov 19, 2018 12:32PM in General Database Discussions

I have already installed Oracle 12c in my windows machine.

I am trying to create new database using DBCA. I am facing issue while given password for Oracle Home User Password(Incorrect Oracle Home User Password)

I have tried to reset the password. But getting the below error.

C:\Users\Admin>orahomeuserctl updpwd -user oracle
Enter new Password:
OHUC-1026 : unable to authenticate the new password

Any one please suggest to resolve this issue.

Answers

  • top.gun
    top.gun Member Posts: 3,666 Gold Crown
    edited Nov 19, 2018 12:32PM

    https://docs.oracle.com/en/database/oracle/oracle-database/12.2/ntqrf/using-the-oracle-home-user-control-tool.html#GUID-…

    "

    The Oracle Home User Control tool accepts the new password at the tool's prompt for password entry and validates the password provided against the password of the Windows User Account. The tool terminates if password validation fails.

    "

    So clearly you got the password wrong.

    It has to match the password you used for the Windows oracle account.

  • User_RGCY4
    User_RGCY4 Member Posts: 1 Red Ribbon

    nope...running into the same problem installing 19c on a machine with 18c. Installed 18c fine some time ago. Installed 19c and tried to upgrade the database. When it gets to the point where you enter the oracle home user, it says the password is incorrect no matter what. I set the password, wrote it down, never changed it, set it to never expire, etc. I tried changing the password of the user account to something else to see if it made any difference. Opened a notepad, made up the password. Cut and pasted into the user manager and saved it. Cut and pasted the same thing into the GUI for the database, it says incorrect password. No idea what the deal is....

  • User_MHW1D
    User_MHW1D Member Posts: 2 Green Ribbon

    Nice to see this issue persists without a definitive reply. I am having this very issue where a local Service Account for the Oracle home user has been created on the windows server with a set and known password but fails during DBCA installation. I have opened multiple SR's and received no effective advice or corrective action. Was this ever resolved on your end?

  • sicun
    sicun Member Posts: 17 Blue Ribbon

    You must first change the Oracle Home User's password in the operating system, then use 'orahomeuserctl updpwd' to update the password used by the Oracle services.

  • User_MHW1D
    User_MHW1D Member Posts: 2 Green Ribbon

    The password for the home user SA has been set within the user credentials locally. The update utility within the DBCA tool suite fails to connect or update. Additionally, the creation of a DB fails once asked to provide the home user password saying its also incorrect. Installation will complete in a non-GPO environment, but this is unacceptable for my workplace and when GPO's were applied the home user was no longer able to run basic DB services to allow access and connectivity. In this case, it appears as though its not communicating and therefore throwing an error due to some policy or permissions. I have sought help with roles and rules from Oracle via multiple SR's and was told that if it will install in a non-GPO environment then the product works but they will not offer advice to complete the installation otherwise. I believe this is a policy issue, but am currently unsure as to what exactly needs to be modified in order to make this work.