Forum Stats

  • 3,733,083 Users
  • 2,246,691 Discussions
  • 7,856,504 Comments

Discussions

/etc/security/limits.conf Setting soft limits not holding after restart

ASGR71
ASGR71 Member Posts: 44 Red Ribbon
edited February 2019 in Database Installation

Hi All,

I'm trying to set the security limits in

     /etc/security/limits.conf

as follows (as suggested by the database installer)

oracle     hard     nofile     65536

oracle     soft      stack     10240

but after restarting the system, the hard limit change

is registered but the soft limit is not. Is there a good

reason for this or not?

Thanks.

A.

SYSTEM:

OEL 7.6

DB 12.2.0.1.0

Answers

  • ASGR71
    ASGR71 Member Posts: 44 Red Ribbon
    edited February 2019

    Ooops!

    My noob mistake, added above.

    Very late night.

    :-(

    I'm sure in OEL7.5 I just pasted the parameters

    into the required files and installation of the DB

    was without interruption.

    The procedure I use is to alter the parameter

    files manually before any DB installation takes

    place. Then I try to run the fixme file in the /tmp

    directory that still fails to alter the soft limit in

    question.

  • ASGR71
    ASGR71 Member Posts: 44 Red Ribbon
    edited February 2019

    Thanks Dude!

    I'll give it a go.

  • JuanM
    JuanM Member Posts: 2,144 Gold Trophy
    edited February 2019

    Can you please copy & paste here the content of you user .bash_profile?

    How are you checking the "new" values? Using cat command? or using a ulimit command?

    Please also check if you have a /etc/security/limits.d/*oracle*.conf file that could be override the limits.conf configuration.

  • ASGR71
    ASGR71 Member Posts: 44 Red Ribbon
    edited February 2019

    Holy Fudge!

    The above yum install ran but still hasn't fixed the soft stack limit!

    It will not budge from 8192 no matter what I try.

    Over the past two weeks I've tried looking at by-passing the PAM

    modules and go straight for systemd/systemctl conf files in different

    locations also without any luck. I've tried filtering the entire contents

    of the /usr/lib/systed directory for any references of LimitSTACK

    but luck there either.

  • ASGR71
    ASGR71 Member Posts: 44 Red Ribbon
    edited February 2019

    Thanks Juan.

    I've been using the ulimit command to view the current settings

    and no other files are in the /etc/security or /etc/security/limit.d

    directories, only the default file. The only thing that does work is setting the limit with

    ulimit -s 10240

  • ASGR71
    ASGR71 Member Posts: 44 Red Ribbon
    edited February 2019

    Also, the ~/.bash_profile has not been altered in any way

    and only contains the default profile template.

  • ASGR71
    ASGR71 Member Posts: 44 Red Ribbon
    edited February 2019

    If I reinstall OEL 7.5, is their a way to stop yum updating my

    system to OEL 7.6? If we can't crack this, I'm tempted to

    report this as a bug.

Sign In or Register to comment.