Forum Stats

  • 3,815,217 Users
  • 2,258,979 Discussions
  • 7,893,004 Comments

Discussions

Install Error [DBT-50000] Unable to check for available memory.

2»

Answers

  • User_6A8K2
    User_6A8K2 Posts: 1 Employee

    If facing dbt-50000-unable-to-check-for-available-memory, at the time of DB Creation, this solutions may help:

    1. Run SETUP.EXE as Administrator
    2. Java Windows when pops-up ALLOW Private and Public Authentication, at the time of DB Software / Binary installations
    3. Run DBCA by opening in CMD as Administrator


  • This is a pretty rough issue that affects 18 XE on Windows. Anyone hitting this should try these steps below. This will not happen in the the next release of XE:



    1) Is ORACLE_HOME or TNS_ADMIN set in the environment? Go to a command prompt, type "set". You will need to temporarily unset any such environment variables.


    2) Are you using Windows 10 Home Edition? It is not supported and the installer is not properly checking for it in the Prerequisite check.


    3) Are you using Server 2019? Same issue.


    4) On your network adapter that you are using, check (enable) "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks".


    5) Check to see if Netbios is enabled on your network connection:

    See this link for more info:


    http://ecross.mvps.org/howto/enable-netbios-over-tcp-ip-with-windows.htm


    6) In some cases, antivirus has interfered with an installation. Try disabling anti-virus.


    7) Try creating a local user and adding to local administrator group and then log in and install as that user.


     

  • ztyzbb
    ztyzbb Member Posts: 1 Green Ribbon
    edited Jul 28, 2021 1:59PM

    I fixed this problem!

    First, part of my logs:

    [Worker 1] [ 2021-07-28 19:38:18.597 CST ] [nativesystem.WindowsNative.Native]  Trying to open a named pipe
    [Worker 1] [ 2021-07-28 19:38:18.597 CST ] [nativesystem.WindowsNative.Native]  About to open pipe
    [Worker 1] [ 2021-07-28 19:38:18.597 CST ] [nativesystem.WindowsNative.Native]  calling create file for pipe \\ZTY-INSPIRON-16-PLUS\pipe\srvmremotexecpipev2
    [Worker 1] [ 2021-07-28 19:38:18.597 CST ] [nativesystem.WindowsNative.Native]  None-pipe-busy error 2
    

    When trying to execute exectask.exe, DBCA will create a named pipe first, and use it to connect to exectask.exe later. But the named pipe create failed. With the help of ProcessMonitor, i got true reason: NAME_NOT_FOUND.

    In my situation, my computer name is too long, about 20 characters(use MY-TOO-LONG-COMPUTER-NAME for example), which exceed NetBIOS's limit(15 characters). So my NetBIOS name become MY-TOO-LONG-COM. DBCA use computer name to create a named pipe, but Windows use NetBIOS name to determine which computer the pipe belongs to, so Windows can't create the named pipe.

    After trim computer name to a shorter one, everything works well.

    Maybe it's a bug of DBCA, or I misunderstood something about named pipe? Anyway, it works now :)

  • Thank you for the info. In any case, the next release of XE will not used named pipes so this will no longer be an issue.

    ztyzbb
  • Mr.Leo
    Mr.Leo Member Posts: 40 Blue Ribbon

    Arrived a bit late in the party, but just to say that this smal detail solved my exact problem.

    Why doesn't Oracle install/run this thing as administrator by default?

  • Christian.Shay -Oracle
    Christian.Shay -Oracle Posts: 2,123 Employee
    edited Apr 11, 2022 3:58PM

    The issue is not as simple as that. As you can see, named pipes were involved. We resolved most of these issues in XE 21c (for example, eliminating the dependency on named pipes) and we are now very explicit, both in the dialogs and in the doc about what we mean by "administrator privileges". (We don't mean "run as administrator").