Forum Stats

  • 3,768,724 Users
  • 2,252,841 Discussions
  • 7,874,696 Comments

Discussions

JCE 8 Problem bei einem bestimmten Reports Server

Juergen Menge
Juergen Menge Member Posts: 111 Red Ribbon
edited May 27, 2019 2:35AM in Forms Gruppe

Liebe Kollegen,

heute möchte ich von einem merkwürdigen Phänomen berichten.
Mittlerweile dürfte es sich herumgesprochen haben, dass sich ab JDK 1.8.0_161 der Reports Server kontinuierlich verabschiedet und neu startet:
Oracle Support Note "12.2.1.3.0: Standalone Report Server Restarted Continuously By Node Manager (Doc ID 2400542.1).
Das kann übrigens problematisch werden, wenn man es nicht merkt, denn der Reports Server ist in den kurzen Intervallen zwischen den Abstürzen ansprechbar und die Log Files laufen voll.
Ich habe zunächst die JCE 8 Policy Files, die zum Download angeboten werden, nicht in alle Verzeichnisse korrekt eingespielt. Habe dann den Fehler bemerkt und korrigiert.
Und jetzt kommt das Merkwürdige. Ab diesem Zeitpunkt kann ich neue Reports Server anlegen und problemlos starten. Wenn ich aber den zuerst angelegten Reports Server als Komponente entferne und unter dem alten Namen neu anlege, bekomme ich dieselben Fehler (kontinuierlicher Restart) wie vorher. Der Name dieses Reports Servers ist quasi "verbrannt". Ich habe eine Volltext-Suche im ORACLE_HOME und im JAVA_HOME durchgeführt, finde aber keine Relikte des alten Reports Servers. Auch ein Reboot der Maschine behebt das Problem nicht.
Vielleicht gibt es im Infrastruktur-Repository noch eine Referenz? Gibt es einen Java Cache auf dem Server?
Aber vielleicht hat jemand eine Idee ...

Gruß Jürgen

Answers