Oracle.ManagedDataAccess dll not included when building — oracle-tech

    Forum Stats

  • 3,716,000 Users
  • 2,242,928 Discussions
  • 7,845,734 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Oracle.ManagedDataAccess dll not included when building

51770adf-6176-4f6d-bd0a-93d27305e6ef
edited April 2019 in ODP.NET

I have a solution with multiple projects in it. One of those projects is a .net standard 2.0 library which references Oracle.ManagedDataAccess.Core nuget package. The main project is an ASP.NET Web API 2 project which targets .net 4.7.2. the asp.net project references the data access library.

When I build the library directly and when I build/debug the API, neither of them are generating the oracle.manageddataaccess dll in the output folder which is causing a missing assembly reference error when I try to debug the API.

Any idea why it would not be outputting the oracle library? I have tried cleaning/rebuilding/etc. and re-installing the nuget package. I can't figure out how to make it stick the dll in the output directory.

If it matters, my IISExpress is running with x64 bitness and my project is targeting x64. I have tried targeting any cpu and that doesn't help.

Any ideas?

Thank You

Sign In or Register to comment.