Forum Stats

  • 3,750,522 Users
  • 2,250,187 Discussions
  • 7,866,997 Comments

Discussions

Workspace

3631507
3631507 Member Posts: 45
edited Sep 16, 2019 9:12PM in R Technologies

I've been using ORD 3.3.0 without problems. I then wanted to try out R 3.6.0 using RStudio. After that attempt, I've been having problems with one of two rqusers that I've created. The error message is

Error in readRDS(pfile) :   cannot read workspace version 3 written by R 3.6.0; need R 3.5.0 or newer

Interestingly, it doesn't happen to the rquser on the same PDB. I read that APEX is needed to delete the workspace but have not been successful in installing that. I tried deinstalling and reinstalling Oracle 12.2.0 but the same error message appears. How can I solve this problem without resorting to APEX?

Tagged:

Answers

  • Sherry Lamonica-Oracle
    Sherry Lamonica-Oracle Posts: 437 Employee
    edited Jun 20, 2019 10:58AM

    The latest version of Oracle R Enterprise (version 1.5.1) has not been tested or certified with R-3.6.0.  See Table 1-3 in this section of the Oracle R Enterprise Installation Guide for a compatibility matrix between R, ORE and Oracle Database.  R-3.4.4 is not officially certified with ORE 1.5.1, but with a few changes it works.

    However, the specific error you are seeing is from open source R and RStudio and not ORE or Oracle Database.  This error can happen if you upgrade R but not your installed packages, or if RStudio is looking for packages in the old R library path.

    Sherry

    3631507
  • 3631507
    3631507 Member Posts: 45
    edited Sep 16, 2019 8:56PM

    Thank you for the clarification.