Forum Stats

  • 3,784,353 Users
  • 2,254,928 Discussions
  • 7,880,790 Comments

Discussions

Need compatibility chart for what instantclient versions work with what particular microsoft OS

BruceTMoose
BruceTMoose Member Posts: 21 Red Ribbon
edited Aug 20, 2019 1:26PM in ODBC

Another person who needs installed help with InstantClient 19_3 asked me to look into an issue with it and Microsoft Server 2008 R2.

I noticed there is a great chart for what Oracle client is compatible with what Oracle server version - but what I'm looking for here is what versions of the Instant Client work on what OS's (better yet, what OS's are supported).  I have done a fair number of searches but have not been able to find a chart like the client/database version one.

I did see an article on a non-oracle forum that was a person asking about issues they saw with the instant client and Windows Server 2008 R2 and they said they ended up installing the full client instead and going that route.

If you want any particulars, we were trying the 32 bit version of ODBC and the client was 19_3 and the client is being installed on a Windows Server 2008 R2 system that already has a prior (version 11 somethign) client on it.  It's possible the two are butting heads, but at least I thought I could find a compatibility chart to see if we were even in the ballpark.  I do realize that Windows Server 2008 R2 is getting really old and yes there are active plans to replace it but for now we need it to talk to a 12.2 database.

Tagged:
Hemy

Best Answer

  • BruceTMoose
    BruceTMoose Member Posts: 21 Red Ribbon
    edited Aug 20, 2019 1:26PM Accepted Answer

    I ended up having someone put in a ticket for this to Oracle support and here is what was told to us

    For Windows Server 2008 R2, the last supported ODBC release is 12.1.0.2.0

    For Windows server 2012 and above, version 19.3 and below is supported

    No one including Oracle support has pointed me to a chart saying "for this OS, here is the last supported ODBC version" - that would have been very helpful.

    Hemy

Answers

  • BruceTMoose
    BruceTMoose Member Posts: 21 Red Ribbon
    edited Aug 20, 2019 1:26PM Accepted Answer

    I ended up having someone put in a ticket for this to Oracle support and here is what was told to us

    For Windows Server 2008 R2, the last supported ODBC release is 12.1.0.2.0

    For Windows server 2012 and above, version 19.3 and below is supported

    No one including Oracle support has pointed me to a chart saying "for this OS, here is the last supported ODBC version" - that would have been very helpful.

    Hemy