ef core + .net core — oracle-tech

    Forum Stats

  • 3,716,134 Users
  • 2,242,961 Discussions
  • 7,845,841 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

ef core + .net core

user5716448
user5716448 Member Posts: 1,683 Silver Badge
edited October 2019 in ODP.NET

Hi,

Have an app which uses .net core 2.2. and oracle ef core.

Looking at https://dotnet.microsoft.com/platform/support/policy/dotnet-core  looks like net core 3.0 is available.

Couple of questions

1)  Anyone know when oracle ef core will be available for net core 3.0

looks like latest release still needs .net core 2.2.

Microsoft.EntityFrameworkCore.Relational (>= 2.1.11 && < 3.0.0)

2) Looks like .net core 2.2. support ends 23/12/2019 - notice support for 2.1 mentions supported for 3 years from 2018 (i.e. would be supported until August 2021 )

   Is that right that support for .net core 2.2 ends before 2.1?  in which case will oracle ef core be available for net core 3.0 before 23/12/2019?

Thanks

Best Answer

  • Alex Keh-Oracle
    Alex Keh-Oracle Posts: 2,753 Employee
    edited October 2019 Accepted Answer

    The Oracle EF Core 19.5 version is certified with EF Core 2.1. It can use either 2.1 or 2.2.

    Yes, .NET Core 2.2. ends before 2.1.

    We don't have a timeline yet on an EF Core 3 provider. We're still assessing the work needed, which will inform us the time it will take.

Answers

Sign In or Register to comment.