Forum Stats

  • 3,734,156 Users
  • 2,246,898 Discussions
  • 7,857,139 Comments

Discussions

SQLcl is not a drop-in-replacement for SqlPlus

user2976118
user2976118 Member Posts: 1
edited Nov 14, 2019 11:20AM in SQLcl

I was excited to learn that there is finally a better CL interface for the ORACLE database.

The video tutorial and docs said it supports all the command line options that SqlPlus does, so I downloaded SQLcl and tried myself:

Can not even login. Works fine with SqlPlus and SqlDeveloper but not with SQLcl. Tried the different syntaxes (EasyConnect, TNS) but no joy.

=> Confirmed my opinion that with ORACLE to get anything working is never easy.

=> Spent a few hours trying to simplify my work but now time is up: That's it for me, SQLcl deleted.

Andris Perkons-Oracle

Answers

  • Erik van Roon
    Erik van Roon Member Posts: 57 Red Ribbon
    edited Oct 30, 2019 3:19PM

    It's a shame that you have such negative experience with SQLcl.

    Pesonally I have never ever had any issues connecting with any of the versions.

    But that doesn't mean you can't have.

    What I think is most unfortunate, however, is that your first 'cry for help' is "it doesn't work, I quit".

    There are some awesomely knowledgeable people active on this forum.

    A post that listed what you tried and showed the exact responses might have triggered someone to hint you towards a solution. No guarantees of course. But you are very unlikely to get any helpfull response if you try on your own until you've passed the point of no return, give up frustrated and even then only share your frustration without any information to work with.

    Andris Perkons-Oracle
  • Turloch O'Tierney-Oracle
    Turloch O'Tierney-Oracle Member Posts: 1,041 Employee
    edited Nov 14, 2019 11:20AM

    Connection/startup issues

    Getting started issues - make sure JDK/JRE is recent oracle (not open jdk) 1.8

    UNIX

    Try unsetting ORACLE_HOME - older Oracle (11?) causes issues conflict with shipped with the database oci/JDBC'thick' driver. - or try remote login from another machine with no ORACLE_HOME  (not sure how to hide 'baked into the registry' ORACLE_HOME in Windows)

    Windows sql.exe

    (Looks in one 1 default place for jdk/jre if that fails) tries in 'Program Files' for jdk jre (rather than PATH)

    Strange terminals might confuser (cygwin etc).

Sign In or Register to comment.