Forum Stats

  • 3,769,484 Users
  • 2,252,969 Discussions
  • 7,875,053 Comments

Discussions

19.2 bug fixes - ETA?

Tomek
Tomek Member Posts: 221 Bronze Badge
edited Dec 18, 2019 12:59PM in APEX Discussions

19.2 provides some long waited REST related functionality. Unfortunately, there some bugs that are making the new futures unusable. I understand the bugs are logged and the team is working on the fixes. I wonder if there is an estimate for the patch release? I would like to understand if this going to be few months or few weeks. It would help with my development planning.

Tagged:
unficypSven W.Scott Wesley

Answers

  • fac586
    fac586 Senior Technical Architect Member Posts: 20,113 Red Diamond
    edited Nov 21, 2019 4:08AM
    Tomek wrote:19.2 provides some long waited REST related functionality. Unfortunately, there some bugs that are making the new futures unusable. I understand the bugs are logged and the team is working on the fixes. I wonder if there is an estimate for the patch release? I would like to understand if this going to be few months or few weeks. It would help with my development planning.

    Supposedly there will not be any patch releases. If the previous policy regarding patch set exceptions is followed, PSEs will only be available to customers with Oracle support contracts. If you don't have support you may therefore be waiting months for 20.1.

  • unficyp
    unficyp Member Posts: 183 Blue Ribbon
    edited Nov 22, 2019 4:25AM

    Looks like Patch 30392181: PSE BUNDLE FOR APEX 19.2 (PSES ON TOP OF 19.2.0.00.18) is out

  • Hilary Farrell-Oracle
    Hilary Farrell-Oracle Software Development Senior Manager Member Posts: 2,323 Employee
    edited Nov 22, 2019 8:20AM

    Hi unficyp,

    Yes indeed - I uploaded the first 19.2 PSE Bundle to MyOracleSupport (MOS) earlier this morning. On MOS, navigate to 'Patches & Updates', and search for patch number 30392181. This is rolling patch, and will be updated with new bug fixes (for severe/prioritised bugs) as and when they are fixed by the team.  Please ensure that you refer to the README.txt file for the list of bugs fixed, and instructions on installation of the patch.

    Since our 18.1 release, we make PSE Bundles available for a given release.  These bundles contain a number of bug fixes - rather than providing individual PSEs for a given bug.  The Known Issues page for a given release will state the PSE Bundle bug number.  We will be shortly updating the 19.2 Known Issues page, to highlight the bugs fixed in the bundle.

    Regards,

    Hilary

    unficyp
  • bansak@loxinfo.co.th
    [email protected] Member Posts: 22 Blue Ribbon
    edited Dec 5, 2019 10:16AM

    I am new on oracle apex 19.2. I would like to download Patch Set Bundle for Oracle APEX 19.2  (30392181) but I can't download because I don't have 'support identifier'. Could you please send patch 30392181 file to me by email.?

    Thanks in advance and Best regards,

    Bansak ([email protected])

  • Sven W.
    Sven W. Member Posts: 10,534 Gold Crown
    edited Dec 12, 2019 3:04AM

    @Hilary Farrell-Oracle Can we check in an existing APEX environment which PSE bundle is installed?


    And since this is a rolling patch we can then still be not sure whether a specific bug is fixed even if the bundle was installed previously.

    So it would be good to know when a newer version of a PSE is available somehow. I just don't understand how we can get this information, especially for a system where some previous DBA installed APEX.

  • Hilary Farrell-Oracle
    Hilary Farrell-Oracle Software Development Senior Manager Member Posts: 2,323 Employee
    edited Dec 18, 2019 12:59PM

    Hi Sven,

    I hope you're keeping well.

    [Note: modified the first paragraph below Dec 18th]

    To check whether the patch has been installed in an existing APEX environment, check for the existence of a preference named 'APEX_19_2_0_PATCH_30392181', as follows ( as outlined in README.txt contained within the patch zip, as of Dec 18th):

    1. Connect to the database where Oracle Application Express is installed as the SYS user
       

    sqlplus sys as sysdba

    2. Run the following select statement to show where the PSE Bundle patch has been applied
       

    select APEX_INSTANCE_ADMIN.GET_PARAMETER('APEX_19_2_0_PATCH_30392181') from dual;

    - and if set, its value will be the date upon which the patch was applied.

    This is indeed a rolling patch, and with that in mind, we actually update the 19.2 Known Issues page and the APEX download page every time the bundle is refreshed on MOS.  As you'll see, we released a revised version of the patch just yesterday.  The README.txt file contained within the patch is updated each time a bug fix is added.  The patch can also be reapplied to an environment, if, as you say, you're unsure whether a specific bug fix has yet been applied.  I should also add that David (@orcl_dpeake) tweeted about the availability of the revised PSE bundle yesterday too - so you should expect to see a tweet either from David or our team (@OracleAPEX) Twitter account.  It's all in an effort to better communicate to the community when a revised patch is available.

    I hope this helps.

    Regards,

    Hilary

    Sven W.Scott Wesley
  • MatthiasHoys
    MatthiasHoys Member Posts: 369
    edited Dec 17, 2019 3:42AM

    @Hilary Farrell-Oracle,

    Yesterday I installed patch set bundle 30392181 on top of a new 19.2 installation on Oracle XE 18c - in my case APEX is installed in the pluggable database XEPDB1 (so I had to run catpatch.sql to install the patch set bundle).

    The installation went fine, but when I execute "select apex_util.get_preference('APEX_19_2_0_PATCH_30392181') from dual", it returns NULL.

    Any thoughts? I uploaded my catpatch.log file.

    Thanks,

    Matthias

  • Hilary Farrell-Oracle
    Hilary Farrell-Oracle Software Development Senior Manager Member Posts: 2,323 Employee
    edited Dec 17, 2019 3:47AM

    Hi Matthias,

    You've raised a question in a separate thread, so lets please stick to one thread - APEX 19.2 patch set bundle still shows 19.2.0.00.18 as version - is this ok?

    Regards,

    Hilary

    Scott Wesley
  • MatthiasHoys
    MatthiasHoys Member Posts: 369
    edited Dec 17, 2019 5:47AM

    Yes, let's stick to one thread indeed - I just found something and added it there.

    Thanks

    Matthias