Forum Stats

  • 3,768,556 Users
  • 2,252,810 Discussions
  • 7,874,618 Comments

Discussions

Windows 10 1809 ODBC Data Source Administrator Crash Oracle 19c Client

user4987584
user4987584 Member Posts: 1
edited Jun 19, 2020 12:35PM in ODBC

Hi Everyone,

I have installed Windows 10 1809 and Oracle 19c Client with ODBC.

In the ODBC Data Source Administrator (32-bit) the "Oracle in OraClient19Home1_32bit" driver works fine.

But when I try to use the "Microsoft ODBC for Oracle" File MSORCL32.DLL with version 10.00.17763.01 the ODBC Data Source Administrator crashes.

I can find following information in the eventvwr.

Faulting application name: odbcad32.exe, version: 10.0.17763.1, time stamp: 0xecf45257

Faulting module name: ntdll.dll, version: 10.0.17763.831, time stamp: 0x6071cf9d

Exception code: 0xc0000005

Fault offset: 0x0004fe05

Faulting process id: 0x245c

Faulting application start time: 0x01d5ab7b4919c9e8

Faulting application path: C:\WINDOWS\syswow64\odbcad32.exe

Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll

Report Id: b9dc3f1e-e97a-468a-aaf9-ef607a63d3d4

Faulting package full name:

Faulting package-relative application ID:

I did not have this problem with the Oracle 12 Client.

Thanks,

Stephan

Answers

  • user2957415
    user2957415 Member Posts: 1 Blue Ribbon
    edited Dec 19, 2019 11:48PM

    I also have the same trouble, could anyone here help?

  • How2VBA
    How2VBA Member Posts: 1
    edited Jan 27, 2020 9:54AM

    i got exactly the same Problem with Creating an ODBC Data Source with "Microsoft ODBC for Oracle"

    Using the official Oracle Client für ODBC is NOT an option for me because Microsoft Access doesn't like this Client.

    In my case, it has to be "Microsoft ODBC for Oracle"

    And I need urgently a solution for this Problem !

    I have already tried to replace and register the msorc32.dll in C:\Windows\SysWOW64\ with a newer one with no success !

  • user9527260
    user9527260 Member Posts: 2
    edited Feb 11, 2020 3:38PM

    I have also the exact same problem. ODBC crashes when adding the Microsoft ODBC driver for Oracle

    But the system is Windows Server 2019 1809 with oracle client 19.0.0.1 32 bit installed.

    If I install that from command line, it will shows no error but nothing was added to the System DSN

    %SYSTEMROOT%\syswow64\odbcconf.exe /a {configsysdsn "Microsoft ODBC for Oracle" "DSN=dev|SERVER=dev"}

    The event log is as follows:

    Log Name:      Application

    Source:        Application Error

    Date:          11/02/2020 2:56:29 PM

    Event ID:      1000

    Task Category: (100)

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      WIN2019

    Description:

    Faulting application name: odbcad32.exe, version: 10.0.17763.1, time stamp: 0xecf45257

    Faulting module name: ntdll.dll, version: 10.0.17763.1, time stamp: 0xb5be830e

    Exception code: 0xc0000005

    Fault offset: 0x0004f1f5

    Faulting process id: 0x1698

    Faulting application start time: 0x01d5e07e73f451a0

    Faulting application path: C:\Windows\syswow64\odbcad32.exe

    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

    Report Id: f69fb553-a42f-4425-aee5-acb00a3e5947

    Faulting package full name:

    Faulting package-relative application ID:

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Application Error" />

        <EventID Qualifiers="0">1000</EventID>

        <Level>2</Level>

        <Task>100</Task>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2020-02-11T01:56:29.122658800Z" />

        <EventRecordID>319</EventRecordID>

        <Channel>Application</Channel>

        <Computer>WIN2019</Computer>

        <Security />

      </System>

      <EventData>

        <Data>odbcad32.exe</Data>

        <Data>10.0.17763.1</Data>

        <Data>ecf45257</Data>

        <Data>ntdll.dll</Data>

        <Data>10.0.17763.1</Data>

        <Data>b5be830e</Data>

        <Data>c0000005</Data>

        <Data>0004f1f5</Data>

        <Data>1698</Data>

        <Data>01d5e07e73f451a0</Data>

        <Data>C:\Windows\syswow64\odbcad32.exe</Data>

        <Data>C:\Windows\SYSTEM32\ntdll.dll</Data>

        <Data>f69fb553-a42f-4425-aee5-acb00a3e5947</Data>

        <Data>

        </Data>

        <Data>

        </Data>

      </EventData>

    </Event>

  • Christopher Jones-Oracle
    Christopher Jones-Oracle Member Posts: 1,643 Employee
    edited Feb 17, 2020 8:53PM

    Please list the VS redistributable versions you have installed - for 19c you need VS redistributable 2017.

  • user9527260
    user9527260 Member Posts: 2
    edited Feb 18, 2020 3:40PM

    Hi cj,

    Thanks for your reply.

    I have tried VS redistributable 2017 and VS redistributable 2019.

    But they both crashed with the said error in event log.

  • User_0DSD0
    User_0DSD0 Member Posts: 1 Red Ribbon
    edited May 28, 2020 7:51AM

    Hi,

    same problem here :

    - Oracle 19c 32 bit client, when opening ODBC 32bits, and choosing "Microsoft Odbc for oracle"  on Windows Server 2019 or Windows Server 2016 , --> crash

    I installed VS redistributable but nothing better...

    has anyone solved this problem ?

  • 4260602
    4260602 Member Posts: 1
    edited Jun 1, 2020 6:15AM

    Hi,

    I have similiar problem. Oracle Db Home1 19c installed on one PC Windows 10 64 bit,

    Oracle Client ODBC 32 bit installed on second PC also Windows 10 64bit.

    I can create DSN on both PCs, also test connection works without problem.

    But when I want create connection from my application (developed in Alaska Xbase++ with SQL Express++ library from Boris Borzic)  error occur :

    Windows 8 06.02 Build 09200, SQLXpp: 3.3.00, Runtime: 2.00.554

    SQLState: IM003,  ErrorCode:160

    Specified driver could not be loaded due to system error  1114: A dynamic link library (DLL) initialization routine failed. (Oracle in instantclient_19_6, C:\Oracle\Product\Client\instantclient_19_6\SQORA32.dll).

    I tryed everything, Visual C++ redistributable installed version 2010 ,2015-2019  32 bit, 64bit etc. two week I working on it.

    SQORA32.DLL is on its place, Oracle_home ,TNS_ADMIN set correctly.

    This looks to some with Windows 10 updates 1903-2004, Visual C++ redistrubutable and Oracle ODBC client.

    Interesting is, that I can coonect with Devart ODBC driver 32/64 bit without problems ! There is no problem, but I need realize connection with right Oracle ODBC driver/client.

    Any advice please ?

  • Ashish Sahu-Oracle
    Ashish Sahu-Oracle IndiaMember Posts: 2 Employee
    edited Jun 19, 2020 12:35PM

    Oracle client comes with Oracle provided ODBC driver.

    You can use Oracle ODBC driver.

    Please let me know why you want to use "Microsoft ODBC for Oracle".

  • User_NUGCE
    User_NUGCE Member Posts: 1 Green Ribbon

    I have the exact same problem, windows 2016 server, Oracle 19 client, ODBCAD32.exe crashes trying to add a system DSN using Microsoft ODBC for Oracle.

    Using the Oracle provided ODBC is not an option as it does not work well with some legacy applications based on microsoft tools (in this case, Visual Foxpro).

    We will have to defer plattform updating until a workaround is found.

  • User_6GCD7
    User_6GCD7 Member Posts: 1 Green Ribbon
    edited Nov 12, 2021 11:25AM

    We also have exactly the same problem in our company. We use Windows Server 2016 Datacenter with Oracle Client 19c. ODBCAD32.exe crashes trying to add a system DSN using Microsoft ODBC for Oracle or modifying an existing DSN. So we need quickly an solution for this, because we also have some legacy applications that need to use the driver "Microsoft ODBC for Oracle"

    Is there a solution for this?



    Protokollname: Application

    Quelle:    Application Error

    Datum:     12.11.2021 11:25:18

    Ereignis-ID:  1000

    Aufgabenkategorie:(100)

    Ebene:     Fehler

    Schlüsselwörter:Klassisch

    Benutzer:   Nicht zutreffend

    Computer:   xxxxxx

    Beschreibung:

    Name der fehlerhaften Anwendung: odbcad32.exe, Version: 10.0.14393.0, Zeitstempel: 0x57899132

    Name des fehlerhaften Moduls: ntdll.dll, Version: 10.0.14393.4704, Zeitstempel: 0x615bdede

    Ausnahmecode: 0xc0000005

    Fehleroffset: 0x0003df93

    ID des fehlerhaften Prozesses: 0xff24

    Startzeit der fehlerhaften Anwendung: 0x01d7d7af8b7c9b43

    Pfad der fehlerhaften Anwendung: C:\Windows\syswow64\odbcad32.exe

    Pfad des fehlerhaften Moduls: C:\Windows\SYSTEM32\ntdll.dll

    Berichtskennung: 0e5e2244-98de-48ca-acd8-ef725638ad7c

    Vollständiger Name des fehlerhaften Pakets: 

    Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 

    Ereignis-XML:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

     <System>

      <Provider Name="Application Error" />

      <EventID Qualifiers="0">1000</EventID>

      <Level>2</Level>

      <Task>100</Task>

      <Keywords>0x80000000000000</Keywords>

      <TimeCreated SystemTime="2021-11-12T10:25:18.651906900Z" />

      <EventRecordID>6694</EventRecordID>

      <Channel>Application</Channel>

      <Computer>xxx</Computer>

      <Security />

     </System>

     <EventData>

      <Data>odbcad32.exe</Data>

      <Data>10.0.14393.0</Data>

      <Data>57899132</Data>

      <Data>ntdll.dll</Data>

      <Data>10.0.14393.4704</Data>

      <Data>615bdede</Data>

      <Data>c0000005</Data>

      <Data>0003df93</Data>

      <Data>ff24</Data>

      <Data>01d7d7af8b7c9b43</Data>

      <Data>C:\Windows\syswow64\odbcad32.exe</Data>

      <Data>C:\Windows\SYSTEM32\ntdll.dll</Data>

      <Data>0e5e2244-98de-48ca-acd8-ef725638ad7c</Data>

      <Data>

      </Data>

      <Data>

      </Data>

     </EventData>

    </Event>