Forum Stats

  • 3,826,337 Users
  • 2,260,628 Discussions
  • 7,896,905 Comments

Discussions

Unable to install Studio 12.4 on Solaris 11.3

4204944
4204944 Member Posts: 3

Hello All in the Community,

I recently installed newly issued SSL package certificates to access pkg.oracle.com support repositories.  Successfully added the Solaris Studio release repository and named it solarisstudio.  Able to make queries for Solaris Studio 12.4 packages against the publisher, but unable to run even a dry run successfully.

Receive this message:

[[email protected]:~]# pkg install -nv solarisstudio-124

Creating Plan (Running solver): |

pkg install: No matching version of developer/solarisstudio-124 can be installed:

  Reject:  pkg://solarisstudio/developer/[email protected]

  Reason:  No version matching 'require' dependency developer/solarisstudio-124/[email protected],5.11-1.0.0.0 can be installed

    ----------------------------------------

    Reject:  pkg://solarisstudio/developer/solarisstudio-124/[email protected]

    Reason:  No version matching 'require' dependency developer/solarisstudio-124/[email protected],5.11-1.0.0.0 can be installed

      ----------------------------------------

      Reject:  pkg://solarisstudio/developer/solarisstudio-124/[email protected]

      Reason:  All acceptable versions of 'require' dependency on runtime/[email protected],5.11-0.175.2.0.0.42.1 are obsolete

      ----------------------------------------

    ----------------------------------------

Here are my system publisher and SRU.

SunOS vburton2 5.11 11.3 sun4v sparc sun4v

SRU 33 - FMRI: pkg://solaris/[email protected],5.11-0.175.3.33.0.5.0:20180530T183617Z

PUBLISHER                   TYPE     STATUS P LOCATION

solaris        (syspub)     origin   online T <system-repository>

solarisstudio               origin   online F https://pkg.oracle.com/solarisstudio/release/

Portion of console output showing successful query of solarisstudio publisher.

[[email protected]:~]# pkg list -a pkg://solarisstudio/*

NAME (PUBLISHER)                                  VERSION                    IFO

developer/developerstudio-125 (solarisstudio)     12.5-1.0.0.0               ---

developer/developerstudio-125/backend (solarisstudio) 12.5-1.0.0.0               ---

developer/developerstudio-125/c++ (solarisstudio) 12.5-1.0.0.0               ---

developer/developerstudio-125/cc (solarisstudio)  12.5-1.0.0.0               ---

developer/developerstudio-125/code-analyzer (solarisstudio) 12.5-1.0.0.0               ---

Any help will be grateful.

Answers