This site is currently read-only as we are migrating to Oracle Forums for an improved community experience. You will not be able to initiate activity until January 30th, when you will be able to use this site as normal.

    Forum Stats

  • 3,889,872 Users
  • 2,269,775 Discussions
  • 7,916,823 Comments

Discussions

Srvctl start fails for one node due to invalid username / password.

User_PVGP0
User_PVGP0 Member Posts: 6 Red Ribbon
edited Jun 17, 2020 1:30PM in Database Upgrade

Release 19.0.0

OS : RHEL 7

I'm getting the following error on one node of a 2 node rac.

srvctl start database -db abccdb

CRS-5017: The resource action "ora.abccdb.db start" encountered the following error:

ORA-01017: invalid username/password; logon denied

/apps/oracle/product/19.0.0/db/bin> srvctl status database -db abccdb

Instance abccdb1 is not running on node db1-1

Instance abccdb2 is running on node db1-2

Changed the password for sys on node 1 using the orapwd utility as well as in the database.

orapwd file=/apps/oracle/product/19.0.0/db/dbs/orapwabccdb password=<newpassword>

./srvctl config database -db abccdb

Database unique name: abccdb

Database name:

Oracle home: /apps/oracle/product/19.0.0/db

Oracle user: oracle

Spfile: +DATA/ABCCDB/PARAMETERFILE/spfile.1610.1043254455

Password file: /apps/oracle/product/12.1.0/db/dbs/orapwabccdb

note that the password file is pointing to  12.1 home in srvctl. I copied the new  password file to 12.1 home , but still no luck.

any help would be appreciated.

Thanks in advance.

Answers