Forum Stats

  • 3,768,724 Users
  • 2,252,841 Discussions
  • 7,874,696 Comments

Discussions

OHS startet nicht mehr

melman
melman Member Posts: 30 Blue Ribbon
edited Jul 6, 2020 9:22AM in Forms Gruppe

Hallo,

ich habe da ein kleines Problem, der OHS startet in meiner Umgebung nicht mehr, leider kann ich nicht wirklich sehen, was sein Problem ist.

Meine Umgebung sieht wie folgt aus:

OS: AIX 7.2

FMW: 12.2.1.4

Das ganze läuft auf mehreren Servern und nur einer hat kein Problem.

Die Logs melden auch keine nutzbaren Informationen, zumindetst nicht für mich.

Der Start sieht wie folgt aus:

# startComponent.sh ohs1Starting system Component ohs1 ...Initializing WebLogic Scripting Tool (WLST) ...Welcome to WebLogic Server Administration Scripting ShellType help() for help on available commandsReading domain from /wls/oracle/middleware/user_projects/domains/wls12p5_domainConnecting to Node Manager ...<Jul 2, 2020 8:38:56 AM CEST> <Info> <Security> <BEA-090905> <Disabling the CryptoJ JCE Provider self-integrity check for better startup performance. To enable this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true.><Jul 2, 2020 8:38:56 AM CEST> <Info> <Security> <BEA-090906> <Changing the default Random Number Generator in RSA CryptoJ from ECDRBG128 to HMACDRBG. To disable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true.><Jul 2, 2020 8:38:56 AM CEST> <Info> <Security> <BEA-090909> <Using the configured custom SSL Hostname Verifier implementation: weblogic.security.utils.SSLWLSHostnameVerifier$NullHostnameVerifier.>Successfully Connected to Node Manager.Starting server ohs1 ...This Exception occurred at Thu Jul 02 08:41:09 CEST 2020.weblogic.nodemanager.NMException: Received error message from Node Manager Server: [Server start command for OHS server 'ohs1' failed due to: [Failed to start the server ohs1Check log file /wls/oracle/middleware/user_projects/domains/wls12p5_domain/system_components/OHS/ohs_nm.logCheck log file /wls/oracle/middleware/user_projects/domains/wls12p5_domain/servers/ohs1/logs/ohs1.log]. Please check Node Manager log and/or server 'ohs1' log for detailed information.]. Please check Node Manager log for details.Error: Error occurred while performing nmStart : Error Starting server ohs1 : Received error message from Node Manager Server: [Server start command for OHS server 'ohs1' failed due to: [Failed to start the server ohs1Check log file /wls/oracle/middleware/user_projects/domains/wls12p5_domain/system_components/OHS/ohs_nm.logCheck log file /wls/oracle/middleware/user_projects/domains/wls12p5_domain/servers/ohs1/logs/ohs1.log]. Please check Node Manager log and/or server 'ohs1' log for detailed information.]. Please check Node Manager log for details.Use dumpStack() to view the full stacktrace :Exiting WebLogic Scripting Tool.Done

Im Log vom Nodemanager sehe ich folgendes:

Jul 02, 2020 8:38:58 AM oracle.ohs.plugin.nodemanager.OhsProcessManagementPlugin$ProcessImpl startINFO: Starting server ohs1Jul 02, 2020 8:38:58 AM oracle.ohs.plugin.nodemanager.OhsRunCommand executeINFO: Running /wls/oracle/middleware/fr_home/ohs/bin/launch httpd -DOHS_MPM_WORKER -d /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1 -k start -f /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1/httpd.confJul 02, 2020 8:38:58 AM oracle.ohs.plugin.nodemanager.OhsRunCommand runGenericINFO: [Thu Jul 02 08:38:58.581909 2020] [so:warn] [pid 15270376:tid 1] AH01574: module ossl_module is already loaded, skippingJul 02, 2020 8:38:58 AM oracle.ohs.plugin.nodemanager.OhsRunCommand runGenericINFO: Errors will be logged into /wls/oracle/middleware/user_projects/domains/wls12p5_domain/servers/ohs1/logs/ohs1.logJul 02, 2020 8:38:58 AM oracle.ohs.plugin.nodemanager.OhsRunCommand executeINFO: /wls/oracle/middleware/fr_home/ohs/bin/launch httpd -DOHS_MPM_WORKER -d /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1 -k start -f /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1/httpd.conf: exit status = 0Jul 02, 2020 8:38:58 AM oracle.ohs.plugin.nodemanager.OhsProcessHandler buildProcessINFO: Check the instance log file for more information: /wls/oracle/middleware/user_projects/domains/wls12p5_domain/servers/ohs1/logs/ohs1.logJul 02, 2020 8:41:03 AM oracle.ohs.plugin.nodemanager.OhsProcessManagementPlugin$ProcessImpl startWARNING: Failed to start the server ohs1 successfully: attempting to cleanup the processJul 02, 2020 8:41:03 AM oracle.ohs.plugin.nodemanager.OhsRunCommand executeINFO: Running /wls/oracle/middleware/fr_home/ohs/bin/launch httpd -DOHS_MPM_WORKER -d /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1 -k stop -f /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1/httpd.confJul 02, 2020 8:41:03 AM oracle.ohs.plugin.nodemanager.OhsRunCommand runGenericINFO: [Thu Jul 02 08:41:03.629735 2020] [so:warn] [pid 21430586:tid 1] AH01574: module ossl_module is already loaded, skippingJul 02, 2020 8:41:04 AM oracle.ohs.plugin.nodemanager.OhsRunCommand executeINFO: /wls/oracle/middleware/fr_home/ohs/bin/launch httpd -DOHS_MPM_WORKER -d /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1 -k stop -f /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1/httpd.conf: exit status = 0Jul 02, 2020 8:41:04 AM oracle.ohs.plugin.nodemanager.OhsProcessHandler buildProcessINFO: Check the instance log file for more information: /wls/oracle/middleware/user_projects/domains/wls12p5_domain/servers/ohs1/logs/ohs1.logJul 02, 2020 8:41:09 AM oracle.ohs.plugin.nodemanager.OhsProcessManagementPlugin$ProcessImpl buildIoExceptionSEVERE: Failed to start the server ohs1<Jul 2, 2020 8:41:09 AM CEST> <WARNING> <Server start command for OHS server 'ohs1' failed due to: [Failed to start the server ohs1Check log file /wls/oracle/middleware/user_projects/domains/wls12p5_domain/system_components/OHS/ohs_nm.logCheck log file /wls/oracle/middleware/user_projects/domains/wls12p5_domain/servers/ohs1/logs/ohs1.log]. Please check Node Manager log and/or server 'ohs1' log for detailed information.><Jul 2, 2020 8:41:53 AM CEST> <WARNING> <Uncaught exception in server handler: [Invalid argument (Write failed)]>

Wobei die letzte Zeile sich wiederholt, da muss es noch ein weiteres Problem geben, leider kann man auch da nicht sehen, was das genaue Problem ist.

Auf dem Server, auf dem der OHS läuft, kommt diese Meldung auch ständig.

Im ohs1.log sehe ich folgendes:

[2020-07-02T08:38:58.9097+02:00] [OHS] [NOTIFICATION:16] [OH99999] [weblogic] [host_id: wls12p5] [host_addr: 0.0.0.0] [pid: 10944958] [tid: 1] [user:oracle] [VirtualHost: main] WebLogic Server Plugin version 12.2.1.4.0 <WLSPLUGINS_12.2.1.4.0_AIX.PPC64_190912.1848>[2020-07-02T08:38:58.9357+02:00] [OHS] [NOTIFICATION:16] [AH00292] [mpm_worker] [host_id: wls12p5] [host_addr: 0.0.0.0] [pid: 10944958] [tid: 1] [user: oracle] [VirtualHost: main] AH00292: Oracle-HTTP-Server-12.2.1.4.0/2.4.39 (Unix) mod_ossl/12.2.1.4.0 configured -- resuming normal operations[2020-07-02T08:38:58.9359+02:00] [OHS] [NOTIFICATION:16] [AH00094] [core] [host_id: wls12p5] [host_addr: 0.0.0.0] [pid: 10944958] [tid: 1] [user: oracle] [VirtualHost: main] AH00094: Command line: '/wls/oracle/middleware/fr_home/ohs/bin/httpd -D OHS_MPM_WORKER -d /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1 -f /wls/oracle/middleware/user_projects/domains/wls12p5_domain/config/fmwconfig/components/OHS/instances/ohs1/httpd.conf'

Ich habe auch schon geprüft, ob der Port bereits verwendet wird, ist leider nicht der Fall, wober der Port auf 8888 geändert wurde.

Hätte jemand einen guten Tipp, wie man diesen Fehler analysieren könnte?

Oder kennt evtl. jemand dieses Problem?

Schönen Gruß

Knut

Best Answer

  • melman
    melman Member Posts: 30 Blue Ribbon
    edited Jul 6, 2020 9:22AM Accepted Answer

    Hi,

    in der Zwischenzeit habe ich eine Lösung gefunden.

    Ich habe die FMW mit einer lokalen IP und nicht mit localhost konfiguriert, aber der OHS hört nicht auf die IP.

    Standardmäßig ist bei dem OHS das SSL aktiv, aber das konfigurierte Wallet, ist standardmäßige ein selbstsigniertes Wallet, das für localhost konfiguriert ist.

    Also habe ich die Datei $DOMAIN_HOME/config/fmwconfig/components/OHS/ohs1/admin.conf geändert und den Hostnamen/IP für die folgenden Anweisungen auf 127.0.0.1 (localhost) gesetzt:

    Listen

    VirtualHost

    ServerName

    Nach dem Neustart vom Nodemanager und AdminServer, konnte ich den OHS problemlos starten.

    Details findet man unter der Doc ID 2606314.1

    Ich denke, es ist eine gute Idee, localhost anstelle der IP zu verwenden.

    Gruß

    Knut

Answers

  • melman
    melman Member Posts: 30 Blue Ribbon
    edited Jul 6, 2020 9:22AM Accepted Answer

    Hi,

    in der Zwischenzeit habe ich eine Lösung gefunden.

    Ich habe die FMW mit einer lokalen IP und nicht mit localhost konfiguriert, aber der OHS hört nicht auf die IP.

    Standardmäßig ist bei dem OHS das SSL aktiv, aber das konfigurierte Wallet, ist standardmäßige ein selbstsigniertes Wallet, das für localhost konfiguriert ist.

    Also habe ich die Datei $DOMAIN_HOME/config/fmwconfig/components/OHS/ohs1/admin.conf geändert und den Hostnamen/IP für die folgenden Anweisungen auf 127.0.0.1 (localhost) gesetzt:

    Listen

    VirtualHost

    ServerName

    Nach dem Neustart vom Nodemanager und AdminServer, konnte ich den OHS problemlos starten.

    Details findet man unter der Doc ID 2606314.1

    Ich denke, es ist eine gute Idee, localhost anstelle der IP zu verwenden.

    Gruß

    Knut