Forum Stats

  • 3,768,893 Users
  • 2,252,872 Discussions
  • 7,874,786 Comments

Discussions

R-3.6.1 compatible OML4R server packages

User_XOOB7
User_XOOB7 Member Posts: 1 Red Ribbon
edited Sep 9, 2020 11:59AM in R Technologies

Hi,

I can not install OML4R on R3.6.1 because the ORE packages available for download are for 3.3:

library(ORE)

Loading required package: OREbase

Loading required package: OREcommon

Error: package or namespace load failed for ‘OREcommon’:

package ‘OREcommon’ was installed by an R version with different internals; it needs to be reinstalled for use with this R version

Error: package ‘OREcommon’ could not be loaded

The Documentation says OML4R is compatible with R3.6.1 and that the ORE packages need to be specific for that version:

https://docs.oracle.com/en/database/oracle/r-enterprise/1.5.1/oread/install-oracle-R-enterprise-server18c.html#GUID-1B67…

#2 Says: Go to the Oracle Machine Learning for R Downloads page, accept the license agreement, and download the R-3.6.1 compatible OML4R server packages to an installation directory, such as /oml4rserver_install_dir/.

But, Oracle Machine Learning for R Downloads page only has packages for R3.3,

I am missing something?,  can not find any reference on the internet for these packages for R3.6.1

R3.6.1 / Oracle Linux 7.8 / Oracle Database 18c

Thanks for your assistance,

Rod.

Answers