Forum Stats

  • 3,853,878 Users
  • 2,264,288 Discussions
  • 7,905,491 Comments

Discussions

JMC 7 SOCKS Settings

user13284207
user13284207 Member Posts: 3
edited Jul 27, 2020 3:38PM in Java Mission Control

I am trying to connect to a remote host via jump host.  I set up a ssh tunnel and also also a ssh dynamic port forwarding.  I was able to connect using regular jconsole.  However, I am not able to connect with JMC7.

Remote jvm is jdk8 with the following jmxremote settings:

    -Dcom.sun.management.jmxremote

    -Dcom.sun.management.jmxremote.authenticate=false

    -Dcom.sun.management.jmxremote.ssl=false

    -Dcom.sun.management.jmxremote.rmi.port=9051

    -Dcom.sun.management.jmxremote.port=9051

1. I set up the definition in Preferences > General > Network Connections.

    a. Active Provider: Manual

    b. SOCKS with Host: localhost  Port: 5555

    c. all other settings are the default under the Manual active provider

2. Created a JVM Connection using the target ip address and the jmx port (which jconsole is able to connect via the dynamic port forwarding)

    - the connection never succeed - it just hang with "Please wait..." and cursor became the spinning wheel and stuck there

Observations:

1. The SOCKS setting is not saved after I exit the program - so could be a bug.

2. With Jconsole, i specify the "Insecure connectIon" - but I don't see this option in JMC7. Could JMC7 keep trying using SSL to connect?

Any help is appreciated.

Regards

Answers

  • user13284207
    user13284207 Member Posts: 3
    edited Jul 27, 2020 3:38PM

    Quick Update - it took a looong time - like 10 min before the UI w/the meters/dials showed up.  I happen to left it open.  Not sure why it took so long.  A quick trace on ssh -vv - i see a lot of channel <x>: rcvd adjust ddd ... where the ddd is mostly 3 digits.  Not sure what's causing the long connect.

    But when i tried to use the flight recorder, it kept telling me the flight recorder is not enabled.  I added -vmargs -XX:+UnlockCommercialFeatures  -XX:+FlightRecorder

    But still not working.  Will try to find out more.  But still could not fix the 10 min connect time...

    Thanks