Forum Stats

  • 3,854,521 Users
  • 2,264,378 Discussions
  • 7,905,717 Comments

Discussions

Installing 11g and Java

I'm having the most incredibly difficult time trying to install Oracle 11g database, and installing Oracle databases isn't anything I've done before and don't typically tinker with Java. I have a vanilla Windows 2008R2 x64 server. Every time I try to install the database I get an error saying "The Java Runtime Environment was not found at bin\javaw.exe", then mentions to install JRE version 1.3.1 or higher. I've installed and tried these Java versions 8u161, 6u45, 6u24, and 1.3.1_20. But still get the same error. Any ideas?


Answers

  • First Check if the Environment variable is set correctly below are the steps:

    Also, create PATH environment variable on your computer like this (if it doesn't exist already):

    1. Right-click on My Computer/Computer
    2. Properties
    3. Advanced system settings (or just Advanced)
    4. Environment variables
    5. If PATH the variable doesn't exist among "User variables" click New (Variable name: PATH, Variable value : C:\Program Files\Java\jdk1.8.0\bin; <-- please check out the right version, this may differ as Oracle keeps updating Java). ; in the end, enables the assignment of multiple values to PATH variable.
    6. Click OK! Done


    To be sure that everything works, open CMD Prompt and type: java -version to check for Java version and javac to be sure that compiler responds.

    Hope this helps!!

    ~Manish Singh

  • Mudasir Hakak
    Mudasir Hakak Member Posts: 135 Bronze Badge

    In addition,

    once the Java path is set ensure to run the installer as "Run as Administrator"

  • Ok, I made sure the PATH was set, and ran as Admin, but still get error.