Forum Stats

  • 3,722,815 Users
  • 2,244,418 Discussions
  • 7,850,110 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

FRM-18126 (Browser not Found) in Forms 12.2.1.4 Builder starting with STANDALONE Modus

Frank Hoffmann
Frank Hoffmann Member Posts: 768 Gold Badge

Hi ALL,

I installed Forms 12.2.1.4 successful. Then I started Forms my Forms session successful from the builder with FSAL (ONE BUTTON RUN). Today I tried it again and got "FRM-18126 Browser not available" during start. This is strange because I am using the option "Start with Standalone Modus". If I start with browser option it works - but I want to start with FSAL again. Does anyone has a workaround for this?

Frank

Best Answer

Answers

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Member Posts: 6,490 Employee

    Recheck the value of "Browser Location". Also be sure that the browser you are pointing to actually exists. For example if you were previously pointing to C:\Program Files\Mozilla\Firefox, maybe a new version moved the location to C:\Program Files\Firefox. If that happened the location in Builder would be wrong.

    By the way, the browser location is needed even though you may be using FSAL because the browser is also used for other things in the Builder like links to OTN and other online content under Help.

  • Frank Hoffmann
    Frank Hoffmann Member Posts: 768 Gold Badge
    edited February 1

    Mike,

    I forget to mention that my developer installation of 12.2.1.4 was done on a windows2019 sever (datacenter).

    1) First after the installation my call with FSAl and ONEBUTTONRUN worked directly. (without a browser mentioned)

    I had only to add the FSAL Path in the registry FORMS_BUILDER_CLASSPATH (C:\oracle\forms12214\forms\java\frmsal.jar;)

    After a time it stopped working. Everytime then FRM-18126 popped up - with IE32 or IE64 Bit or Firefox Path as Browserpath.

    Here is what I had to do ...

    2.) I had to install Java JRE (32 bit), had to add IE11-32 Path as browserpath "C:\Program Files (x86)\Internet Explorer\iexplore.exe" and had to run Forms ONEBUTTONRUN one time as browserversion successful (no checkbox at standalone launcher)

    After that worked correctly I could take away the Browser entry again (which is also found in HKEY_CURRENT_USER\Software\Oracle\Toolkit\TKBrowser) and switch back to Standalone Launcher Modus, and it works now perfect like in the beginning

    ONEBUTTONRUN FSAL starts the module in 2 seconds

    welcome in mystery castle!

    It seems that after one false Forms Builder call with ONEBUTTONRUN the Builder needs one correct start with IE11 32 Bit / Java 32.

    @Michael Ferrante-Oracle Could you please look into the code? There must be another check which seems to be invisble next to the registry entry of the bowser entry her: HKEY_CURRENT_USER\Software\Oracle\Toolkit\TKBrowser

    FRM-18126 can't be a correct error message because I am able to run FSAL without a TKBrowser entry with the Standalone Checkbox in the preferences. It seems as if the builder stores the case, if a ONEBUTTONRUN was successful or not. And I don't know why sometimes the FORMS_BUILDER_CLASSPATH entry to fsal.jar is necessary and sometimes not. Some clarification here would be very helpful.

    Here is an example of my german FSAL settings that run perfectly with FSAl and ONEBUTTONRUN and OTN HTML calls.

    I address the formsserver directly (9001) because Forms Builder and the weblogic machine are on the same Windows server.

    HKEY_CURRENT_USER\Software\Oracle\Toolkit\TKBrowser is of course empty too.

    All I had to do was this

    FORMS_BUILDER_CLASSPATH add the fsal path (C:\oracle\forms12214\forms\java\frmsal.jar;)

    and after the unlogical FRM-18126 bug to do the workaround under 2.)


    Frank

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Member Posts: 6,490 Employee

    Frank,

    The Builder looks for frmsal.jar in \forms\java. Unless you have moved it or altered the directory name(s), it should be found. I imagine it is possible that if you have other installations on the same machine and ORACLE_HOME is set on the machine (system level) that could cause a problem. Be sure that there are no system settings like PATH, ORACLE_HOME, FORMS_BUILDER_CLASSPATH, or CLASSPATH that could interfere with the Builder installation.

    Also, it is possible that your "config" is causing a problem if it is not properly configured. Keep in mind that the way the Builder works is if it sees "config=" in your Server URL it ignores the default settings (internally) and uses your config. If it does not find a custom config (and you have checked Run Standalone) , it will attempt to use [standaloneapp], so do not remove it from your Web Configuration file.

  • Frank Hoffmann
    Frank Hoffmann Member Posts: 768 Gold Badge

    Mike,

    the reason might be the PATH. I have installed a ORACLE 19.10 DB on the same server. This might be the reason why I had to address fsal.jar in FORMS_BUILDER_CLASSPATH.

    If the Builder looks for \forms\java the Port 9001 might be a problem. I will check if it runs without a problem if I leave the database directories out of the PATH.

    Thank you for your fast response,

    Frank

  • Frank Hoffmann
    Frank Hoffmann Member Posts: 768 Gold Badge
    edited February 2

    Great hints Mike, great help again

    this is what I did -

    >In most cases, newer Oracle products no longer need to have global settings

    1.) I took away all entries from the Windows Server PATH (Database and Forms Path) - no ORACLE related entries left

    2.) I deleted all WINDOWS environment variables (NLS_LANG, ORACLE_HOME) - no ORACLE releated variables left

    3.) I took away the fsal.jar entry from FORMS_BUILDER_CLASSPATH - it seems not to be necessary

    4.) I left the browser entry in the Forms settings empty - it seems no to be needed

    Now everything works perfect - ONEBUTTONRUN ONEBUTTONDEBUG, NLS_LANG comes from default.env.

    So I develop now with Forms/Reports 12.2.1.4, Oracle DB 19.10, SQLCL18.3 from Forms HOME on a CLOUD Windows2019 datacenter.

    Frank

Sign In or Register to comment.