Forum Stats

  • 3,726,956 Users
  • 2,245,297 Discussions
  • 7,852,506 Comments

Discussions

Oracle MAF is not getting deployed on iOS simulator on the Xcode 12.4

Bilal
Bilal Member Posts: 466 Bronze Badge

Hi All,

Firstly, I am not sure if this is the right community to post Oracle MAF questions. I searched the forums and this one seemed the most relevant. Anyway:

Oracle JDeveloper 12c version 12.2.1.3 and latest MAF version 2.6.3.0.42.

I have Xcode latest version which is 12.4 on MacBook Pro.

When I try to deploy the MAF application on iOS simulator, I get the following error saying that I need Xcode 11 or higher for the deployment to work, which in my case is higher i.e. 12.4. See the error below:

[07:01:24 PM] ---- Deployment started. ----
[07:01:24 PM] Target platform is (iOS).
[07:01:24 PM] Beginning deployment of MAF application 'Employees' to iOS using profile 'iOS1'.
[07:01:24 PM] Capturing initial state of MAF application source files in application scope for future just-in-time "Clean All" analysis.
[07:01:24 PM] Unable to determine if application-wide files have changed since a previous deployment. This will require a just-in-time "Clean All" on MAF application build and deployment content to ensure a good deployment.
[07:01:24 PM] Performing just-in-time "Clean All" on MAF application build and deployment content to ensure a good deployment.
[07:01:24 PM] Checking to detect whether a partial deployment can be done.
[07:01:24 PM] Detected: Full deployment is needed
[07:01:24 PM] Capturing initial state of MAF application files to establish a baseline for Quick Deploy analysis.
[07:01:26 PM] Command-line executed: [/Users/m-bilal/Oracle/Middleware/Oracle_Home/jdeveloper/jdev/extensions/oracle.maf/iOS/maf-helper, activeXcodeVersion, -validate]
[07:01:26 PM] Command-line execution failed (Return code: 35)
[07:01:26 PM] Encountered one or more errors returned by "/Users/m-bilal/Oracle/Middleware/Oracle_Home/jdeveloper/jdev/extensions/oracle.maf/iOS/maf-helper". The following is a summary of the returned error(s):
Command-line execution failed (Return code: 35)
Begin Standard Error content.
Error: Unsupported Xcode version 12.4: Xcode must be version 11 (11.0 or later).
End Standard Error content.
Begin Standard Output content.
End Standard Output content.
[07:01:26 PM] Deployment cancelled.
[07:01:26 PM] Deployment cancelled.
[07:01:26 PM] ---- Deployment incomplete ----.
[07:01:26 PM] Failed deployment to iOS simulator. Encountered exception: An error occurred while trying to determine if Xcode is installed..
[07:01:26 PM] An error occurred while trying to determine if Xcode is installed.
[07:01:26 PM] The active version of Xcode is not a supported version for MAF. Please see the MAF support matrix for the supported versions.

Does anyone also witness such an error?

I will greatly appreciate any guidance to resolve the issue.

Many Thanks and

Kind Regards,

Bilal

Best Answer

  • Bilal
    Bilal Member Posts: 466 Bronze Badge
    Accepted Answer

    Hey,

    I downloaded XCode 11 and put in the Applications folder. JDeveloper has started to pick it up.

    Working perfectly.

    Thanks a lot.

Answers

  • Bilal
    Bilal Member Posts: 466 Bronze Badge
    Accepted Answer

    Hey,

    I downloaded XCode 11 and put in the Applications folder. JDeveloper has started to pick it up.

    Working perfectly.

    Thanks a lot.

Sign In or Register to comment.