Forum Stats

  • 3,722,791 Users
  • 2,244,415 Discussions
  • 7,850,094 Comments

Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

blank screen in 12c

Tony007
Tony007 Member Posts: 4,046 Bronze Trophy

hi am running oracle forms 12c in window 10 after i install 12c in solaris 11.4 with java 11.1.8.211

client

in window i have 2 forms 11g and 12c stand alone with java 1.8.40 and java 1.7


other forms are running which i have install running in solaris only this installaion is not running in window 10 i think i have choosen wrong option when i run application for the first at the button of the screen, in 11g i used to install java 1.6 and it works now am in 12c what must i do

Answers

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Member Posts: 6,490 Employee

    @Tony007 I have to say, I can't at all follow what you are saying. Also, you didn't include versions, which might be important here. For example for Forms 12.2.1.4 you must use Java 8u211 or newer on the user tier (end user running form). Also, you will not be able to have multiple Java JRE versions installed. If you do, the newest will always attempt to be used.

    Also, for Forms 12.<something> are you trying to run embedded in the browser or using Web Start or using Forms Standalone Launcher?

  • Tony007
    Tony007 Member Posts: 4,046 Bronze Trophy
    edited March 19

    this the java version i have

    i got this message when running application for the first time

    i click dont enable then i install java 1.8.40 32 bit version i got this message this time i click enable other server are running with forms 12.2.1.4 using java 1.8.211 only this particular server is not runing

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Member Posts: 6,490 Employee

    First, unless you happen to be in one of a very few rare cases, there is no reason to have 64bit JREs installed. You should remove/uninstall these. Second, you should not have more than one version of the same family installed. Therefore you should remove all installations of Java 8u40 (32 and 64 bit). And in this spirit, you should not be using any Java version older than 8. Unless you are running something extremely old, most applets should work correctly with Java 8, so uninstalling Java 7 is a good idea too. That said, as I mentioned if you try to run an app with Java 7, it will load the v8 JVM automatically anyway. The only way to prevent this is with a Deployment Rule Set.

    So to your question/comment: "...i got this message...". So what's the problem? Click Enable and continue.


  • Tony007
    Tony007 Member Posts: 4,046 Bronze Trophy
  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Member Posts: 6,490 Employee

    Let me try again. Follow these exact instructions:

    .1. Close ALL instances of Internet Explorer

    .2. Uninstall JRE 8u40 (x86)

    .3. Uninstall JRE 8u211 (x86)

    .4. Download and install JRE 8u281 (x86)

    .5. Retest. If prompted, click on Enable button regarding Java Plugin

  • Tony007
    Tony007 Member Posts: 4,046 Bronze Trophy

    still having error now working with webstart


  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Member Posts: 6,490 Employee

    You opened this thread saying that there is a blank screen when you try running your form. When you use JWS and launch from the browser, the browser window will be blank because the content is launched in a separate window. So the question is whether or not you have properly configured your "config". If it doesn't include the proper settings for JWS then it won't work.

    In that "blank" browser, open the source (Ctrl+U). If you see something like this it means your configuration is wrong.


    In order to verify your configuration, I would recommend using the command line as a test. Open a command prompt and do this:

    o Ensure that PATH points to Java 8 JRE. Execute: java -version

    o Enter this then press Return: javaws "http://yourserver:9001/forms/frmservlet?config=webstart"

    Assuming you replaced "yourserver" with your server (and the port number with yours, the test form should have been presented. If this works, replace "config=webstart" with your custom config which I assume you created because you blurred it out in the image you shared. If that fails then you just found the issue.

  • Tony007
    Tony007 Member Posts: 4,046 Bronze Trophy

    am geting

    HTML>

    <!-- FILE: basejpi.htm (Oracle Forms)                 -->

    <!--                                 -->

    <!-- This is the default base HTML file for running a form on the   -->

    <!-- web using the JDK Java Plugin. This is used for example when   -->

    <!-- running with Netscape on Unix.                  -->

    <!--                                 -->

    <!-- IMPORTANT NOTES:                         -->

    <!-- Default values for all the variables which appear below     -->

    <!-- (enclosed in percent characters) are defined in the servlet   -->

    <!-- configuration file (formsweb.cfg). It is preferable to make   -->

    <!-- changes in that file where possible, rather than this one.    -->

    <!--                                 -->

    <!-- This file will be REPLACED if you reinstall Oracle Forms, so   -->

    <!-- you are advised to create your own version if you want to make  -->

    <!-- any modifications. You should then set the baseHTMLjpi     -->

    <!-- parameter in the Forms Servlet configuration file (formsweb.cfg) -->

    <!-- to point to your new file instead of this one.          -->

    <HEAD><TITLE>Oracle Fusion Middleware Forms Services</TITLE></HEAD>

    <BODY >

    <!-- COMMENT below is required for legacy-lifecycle support.    -->

    <COMMENT id="forms_plugin_info"

         serverURL="/forms/lservlet?ifcfs=/forms/frmservlet?config=ALPHA_Aunt_12c&#38;ifsessid=WLS_FORMS.formsapp.7&#38;acceptLanguage=en-us">

    </COMMENT>

    <!-- Forms applet definition (start) -->

    <OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"

        codebase=""

        WIDTH="750"

        HEIGHT="600"

        HSPACE="0"

        VSPACE="0"

        ID="">

    <PARAM NAME="java_version" VALUE="1.7+">

    <PARAM NAME="TYPE"    VALUE="application/x-java-applet">

    <PARAM NAME="CODEBASE"  VALUE="/forms/java">

    <PARAM NAME="CODE"    VALUE="oracle.forms.engine.Main" >

    <PARAM NAME="ARCHIVE"  VALUE="frmall.jar" >

    <PARAM NAME="serverURL" VALUE="/forms/lservlet?ifcfs=/forms/frmservlet?config=ALPHA_Aunt_12c&#38;ifsessid=WLS_FORMS.formsapp.7&#38;acceptLanguage=en-us">

    <PARAM NAME="networkRetries" VALUE="0">

    <PARAM NAME="separateFrame" VALUE="true">

    <PARAM NAME="splashScreen" VALUE="">

    <PARAM NAME="background" VALUE="">

    <PARAM NAME="lookAndFeel" VALUE="Oracle">

    <PARAM NAME="colorScheme" VALUE="swan">

    <PARAM NAME="customColorScheme" VALUE="">

    <PARAM NAME="serverApp" VALUE="">

    <PARAM NAME="logo" VALUE="">

    <PARAM NAME="imageBase" VALUE="codebase">

    <PARAM NAME="formsMessageListener" VALUE="">

    <PARAM NAME="recordFileName" VALUE="">

    <PARAM NAME="EndUserMonitoringEnabled" VALUE="false">

    <PARAM NAME="EndUserMonitoringURL" VALUE="">

    <PARAM NAME="heartBeat" VALUE="">

    <PARAM NAME="MaxEventWait" VALUE="">

    <PARAM NAME="allowAlertClipboard" VALUE="true">

    <PARAM NAME="disableValidateClipboard" VALUE="false">

    <PARAM NAME="enableJavascriptEvent" VALUE="true">

    <PARAM NAME="digitSubstitution" VALUE="context">

    <PARAM NAME="legacy_lifecycle" VALUE="false">

    <PARAM NAME="JavaScriptBlocksHeartBeat" VALUE="false">

    <PARAM NAME="highContrast" VALUE="false">

    <PARAM NAME="disableMDIScrollbars" VALUE="">

    <PARAM NAME="clientDPI" VALUE="">

    <PARAM name="applet_stop_timeout" value="800">

    <PARAM name="guiMode" value="0">

    <PARAM name="idleTimeout" value="">

    <PARAM name="ssoLogoutRedirect" value="">

    <PARAM name="ssoMode" value="false">

    <PARAM name="ssoLogout" value="false">

    <PARAM name="logoutTargetURLParamname" value="">

    <PARAM name="mediaBase" value="codebase">

    <PARAM name="separate_jvm" VALUE="false">

    <COMMENT>

    <EMBED SRC="" PLUGINSPAGE="http://www.oracle.com/technetwork/java/javase/downloads"

        java_version="1.7+"

        TYPE="application/x-java-applet"

        java_codebase="/forms/java"

        java_code="oracle.forms.engine.Main"

        java_archive="frmall.jar"

        WIDTH="750"

        HEIGHT="600"

        HSPACE="0"

        VSPACE="0"

        NAME=""

        serverURL="/forms/lservlet?ifcfs=/forms/frmservlet?config=ALPHA_Aunt_12c&#38;ifsessid=WLS_FORMS.formsapp.7&#38;acceptLanguage=en-us"

        networkRetries="0"

        separateFrame="true"

        splashScreen=""

        background=""

        lookAndFeel="Oracle"

        colorScheme="swan"

        customColorScheme=""

        serverApp=""

        logo=""

        imageBase="codebase"

        recordFileName=""

        EndUserMonitoringEnabled="false"

        EndUserMonitoringURL=""

        heartBeat=""

        MaxEventWait=""

        disableValidateClipboard="false"

        allowAlertClipboard="true"

        enableJavascriptEvent="true"

        digitSubstitution="context"

        legacy_lifecycle="false"

        JavaScriptBlocksHeartBeat="false"

        highContrast="false"

        disableMDIScrollbars=""

        clientDPI=""

        applet_stop_timeout="800"

        guiMode="0"

        idleTimeout=""

        ssoLogoutRedirect=""

        ssoMode="false"

        ssoLogout="false"

        logoutTargetURLParamname=""

        mediaBase="codebase"

        separate_jvm="false"

    >

    <NOEMBED>

    </COMMENT>

    </NOEMBED></EMBED>

    </OBJECT>

    <!-- Forms applet definition (end) -->

    </BODY>

    </HTML>

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Member Posts: 6,490 Employee

    If the above HTML is what you are getting in any browser except Internet Explorer, that explains why the app isn't running. If you are using IE, it must be version 11 and as mentioned earlier, you must install and enable (remember the button from above?) a 32bit JRE (version 8U151 or newer).

    If you are using IE11 and given the HTML source you shared, I suspect Java is starting. Meaning, you should have access to the Java Console. There you likely will find the cause of the problem. If Java is not starting then the JRE is either not properly installed or is the wrong version or is being blocked by other software on the machine (e.g. virus scanner, security software, etc).

    For all other browsers you must configure and use Java Webstart. If you want to use a custom configuration section/name, start by copying the Web Configuration named "webstart" then customize the new one as you desire.


Sign In or Register to comment.