Forum Stats

  • 3,734,283 Users
  • 2,246,938 Discussions
  • 7,857,218 Comments

Discussions

Oracle APEX - How to deal with Unresponsive Page when executing in SQL Command ?

Jasper Tanglib
Jasper Tanglib Member Posts: 55 Green Ribbon

Hi,

In Oracle Apex 20.2, when I execute a simple Delete query, the page hangs and just gives off a pop up that says the page is unresponsive.

Code:

DELETE FROM wwv_flow_files where  ID = 19575854524840376

Pop Up:


Not only does this occur when I execute a simple delete query but I also have other codes that triggers this issue such as loops and inserts.

I have already tried to do the following:

  1. Log off from the workspace and relogged in.
  2. Close all browsers and relogged in.
  3. Restarted laptop.

After doing all of the above, I am still encountering the same issue. I have encountered this before but simply relogging into the workspace usually solved it but this time it has become more persistent.


How can I fix this issue?


Any ideas or suggestions are appreciated.

-Jazz

Best Answer

  • Jasper Tanglib
    Jasper Tanglib Member Posts: 55 Green Ribbon
    edited Apr 20, 2021 1:27PM Accepted Answer

    Just a reference for anyone reading this thread.

    We were not sure how to specifically locate the locked rows and table and was taking much time so a workaround that my DBA did was restart the Autonomous database and that seemed to kill all the sessions on the locked rows so now it's working well.

    I think this is not recommended if you have multiple developers and your app should be running all the time.

Answers

Sign In or Register to comment.