Forum Stats

  • 3,784,355 Users
  • 2,254,928 Discussions
  • 7,880,790 Comments

Discussions

Failure in Oracle 18c XE installation in Edition:Windows 10 Pro Version:20H2

User_N09RB
User_N09RB Member Posts: 1 Green Ribbon

Hi,

I am facing issues in installing the Oracle 18c XE in my Win 10 Pro, after one point it hangs and the file trace.log keep increasing in size.it reached to 23GB and i had to stop it. attaching some part of the log here for your reference, the last line repeats that is all i could see. i have checked the Antivirus is off and Client for Microsoft Networks and file sharing is enabled.

Please let me know the solution if there is any, so that i can install it in my PC.

My Windows configuration -

Edition Windows 10 Pro

Version 20H2

Installed on ‎15-‎09-‎2020

OS build 19042.928

Experience Windows Feature Experience Pack

System Configuration -

Device name DESKTOP-PRAMODA

Processor Intel(R) Core(TM) i3-8109U CPU @ 3.00GHz  3.00 GHz

Installed RAM 16.0 GB (15.9 GB usable)

System type 64-bit operating system, x64-based processor


Thanks

Pramoda Kallaje (Bangalore, India)

Log screen below -

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [RemoteExecCommand.copyToolAndDeps:1631] copyResult= 1|SUCCESSFUL

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [NativeResult.<init>:93] NativeResult: The String obtained is1|SUCCESSFUL

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [NativeResult.<init>:101] The status string is: 1

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [NativeResult.<init>:114] The result string is: SUCCESSFUL 1

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [RemoteExecCommand.copyToolAndDeps:1628] Copying file C:\app\pramo\product\18.0.0\dbhomeXE\cv\remenv\pluggable\remove_cvuresource_baseline.bat ...

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [WindowsSystem.copyFile:615]  Source file is C:\app\pramo\product\18.0.0\dbhomeXE\cv\remenv\pluggable\remove_cvuresource_baseline.bat dest is C:\Users\pramo\AppData\Local\Temp\\CVU_18.0.0.0.0_pramo\remove_cvuresource_baseline.bat

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [WindowsSystem.copyFile:616]  Source node is localnode dest is localnode

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [WindowsSystem.copyFile:644] Copy file C:\app\pramo\product\18.0.0\dbhomeXE\cv\remenv\pluggable\remove_cvuresource_baseline.bat to C:\Users\pramo\AppData\Local\Temp\\CVU_18.0.0.0.0_pramo\remove_cvuresource_baseline.bat

[Worker 0] [ 2021-04-25 15:42:51.623 IST ] [nativesystem.WindowsNative.Native] The source and dest dirs are :C:\app\pramo\product\18.0.0\dbhomeXE\cv\remenv\pluggable\remove_cvuresource_baseline.bat , C:\Users\pramo\AppData\Local\Temp\\CVU_18.0.0.0.0_pramo\remove_cvuresource_baseline.bat


[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [nativesystem.WindowsNative.Native] CopyFile status:1 , errNum=0


[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [RemoteExecCommand.copyToolAndDeps:1631] copyResult= 1|SUCCESSFUL

[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [NativeResult.<init>:93] NativeResult: The String obtained is1|SUCCESSFUL

[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [NativeResult.<init>:101] The status string is: 1

[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [NativeResult.<init>:114] The result string is: SUCCESSFUL 1

[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [RemoteExecCommand.execute:1033] Running the command again

[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [RemoteExecCommand.executeInternal:1238] Calling executeInternal()

[Worker 0] [ 2021-04-25 15:42:51.625 IST ] [RemoteExecCommand.executeInternal:1254] executing the command: 'C:\Users\pramo\AppData\Local\Temp\CVU_18.0.0.0.0_pramo\\exectask.exe' with args '-getver ', 'm_stdin == null ->true', 'm_localExecution ->true', 'm_chkException ->false'

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [Utils.getLocalHost:479] Hostname retrieved: DESKTOP-PRAMODA, returned: DESKTOP-PRAMODA

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [WindowsSystem.dorunRemoteExecCmd:3044] _WS_: Calling windowsNative with cmd: C:\Users\pramo\AppData\Local\Temp\CVU_18.0.0.0.0_pramo\\exectask.exe

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] sprvmjni: isCopy=1 cmd=C:\Users\pramo\AppData\Local\Temp\CVU_18.0.0.0.0_pramo\\exectask.exe


[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] sprvmjni: isCopy=1 node=DESKTOP-PRAMODA


[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] num args: 1 


[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] args[0] = -getver


[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] Trying to open a named pipe

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] About to open pipe

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] calling create file for pipe \\DESKTOP-PRAMODA\pipe\srvmremotexecpipev2

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] Local pipe failed (53), retry using local pipe notation

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] calling create file for pipe \\.\pipe\srvmremotexecpipev2

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] Created handle to Pipe 


[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] Pipe has connected, set the handle state

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] Fill up the request message

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] Finish filling up the request message

[Worker 0] [ 2021-04-25 15:42:51.626 IST ] [nativesystem.WindowsNative.Native] Sending a message to the pipe server. Total bytes to write=18528

[Worker 0] [ 2021-04-25 15:42:51.628 IST ] [nativesystem.WindowsNative.Native] After call to WriteFile. totalWritten=18528, cbWritten=18528

[Worker 0] [ 2021-04-25 15:42:51.628 IST ] [nativesystem.WindowsNative.Native] Reading from the pipe

[Worker 0] [ 2021-04-25 15:42:51.628 IST ] [nativesystem.WindowsNative.Native] Reading from the pipe

[Worker 0] [ 2021-04-25 15:42:51.628 IST ] [nativesystem.WindowsNative.Native] Reading from the pipe

[Worker 0] [ 2021-04-25 15:42:51.628 IST ] [nativesystem.WindowsNative.Native] Reading from the pipe

[Worker 0] [ 2021-04-25 15:42:51.628 IST ] [nativesystem.WindowsNative.Native] Reading from the pipe

[Worker 0] [ 2021-04-25 15:42:51.628 IST ] [nativesystem.WindowsNative.Native] Reading from the pipe

Answers

  • Please check common issues #4, #5 and #6 below as they are the frequent cause of this issue:


    1) Is ORACLE_HOME or TNS_ADMIN set in the environment? Go to a command prompt, type "set". You will need to temporarily unset any such environment variables.


    2) Are you using Windows 10 Home Edition? It is not supported and the installer is not properly checking for it in the Prerequisite check.


    3) Are you using Server 2019? Same issue.


    4) On your network adapter that you are using, check (enable) "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks".


    5) Check to see if Netbios is enabled on your network connection:

    See this link for more info:


    http://ecross.mvps.org/howto/enable-netbios-over-tcp-ip-with-windows.htm


    6) In some cases, antivirus has interfered with an installation. Try disabling anti-virus and then installing.


    7) Try creating a local user and adding to local administrator group and then log in and install as that user.


     

    If any of these work for you, please report back and let me know.