Forum Stats

  • 3,734,237 Users
  • 2,246,916 Discussions
  • 7,857,196 Comments

Discussions

Liquibase lb genobject -type apex

Agustin Conejos
Agustin Conejos Member Posts: 15 Green Ribbon

Hello i am using SQLcl: Release 21.1

On my windows machine..


 sql> lb genschema -split works like a charm..


Running

sql> lb genobject -type apex -applicationid 1000 -skipExportDate -expOriginalIds -split


I get the error

Processing has failed for your request.

Illegal char <:> at index 41: C:\Users\Apps\repo\apex\/C:\Users\Apps\repo\apex\f1000/application/pages/page_00101.xml


My guess it bugs the path \ from windows.

Tried by running from the gitbash terminal and same error...

Answers

  • Agustin Conejos
    Agustin Conejos Member Posts: 15 Green Ribbon

    there are 2 issues .. one side is windows issue for // and \\ but the other is that the path is pasted twice


    in linux

    $ pwd

    /dev/repo

    SQLcl: Release 20.2 Production on Tue May 25 09:10:16 2021

    Connected to:

    Oracle Database 18c Enterprise Edition Release 18.0.0.0.0 - Production

    Version 18.12.0.0.0

    SQL> lb genobject -type apex -applicationid 100 -skipExportDate -expOriginalIds -split

    Exporting application 100

     Completed at Tue May 25 09:10:26 CDT 2021

    Action successfully completed please review created file controller.xml


    $ cd dev/repo/

    $ ls

    f100

    $ pwd

    /dev/repo/dev/repo


    Created the path again and then extracted the applicationid

Sign In or Register to comment.