Forum Stats

  • 3,836,793 Users
  • 2,262,193 Discussions
  • 7,900,114 Comments

Discussions

unable to import from data dictionary

I tried to import tables of a database (12.1.0.1.0) schema into datamodeler. After selecting the tables I got a lot of "java.sql.SQLRecoverableException: Closed Connection". The import shows only the tables but no columns.

am using SQL Developer Data Modeler 20.4.1.406.0906 (I tried a newer version with the same result) our infrastructure has changed and the networksettings might have changed. I looked up a lot of posts concerning the java error. But I have no clue how solve the problem. From the database point of view nothing has changed.

help is really appreciated

kind regards Raimund

Comments

  • Raimund Kelterer
    Raimund Kelterer Member Posts: 10 Blue Ribbon

    During futher investigation I found an error in the database trace: ORA-03137 TTC protocol internal error : [12333] [11] [83] [84] [] [] [] []. On a 12.1.0.2 database I am getting no error. So I think it is a 12.1.0.1 bug :-(

    Futhermore I tried to do the import with a Data Modeler 17.2.0.188.1059 -- and it worked even on a 12.1.0.1.