Forum Stats

  • 3,733,838 Users
  • 2,246,829 Discussions
  • 7,856,890 Comments

Discussions

Which parameters are use with the recent Java update?

Sho_Will
Sho_Will Member Posts: 4 Green Ribbon

The recent Java update 1.8.291 has caused a “ClassNotFoundException” JavaVersionDisplayApplet3_4 and oracle.forms.engine.Main. Previously with update 1.8.281 I was able to bypass this error using TLS 1.1 under the Java advanced parameters. Please advice with the new Advanced settings.

Answers

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 6,627 Employee

    Be sure you are running Forms 12.2.1.3 or 12.2.1.4. Ideally, you should be using 12.2.1.4.

  • Sho_Will
    Sho_Will Member Posts: 4 Green Ribbon

    Our team server runs on Oracle Forms 11, are there still parameters for this version?

  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 6,627 Employee

    Without knowing the exact and complete error message you are seeing and what your app is doing to expose it, telling you how to get around it may not be possible. Likely the partial error information you shared is the result of custom Java code you added to your app using Java APIs that are no longer supported or something similar. Alternatively, it is just an incompatibility with the obsolete version of Forms you are using and the new Java version.

    Forms 11.1.1 has been desupported since 2014 and v11.1.2 since 2016. So, it is very important that your team start working on an upgrade plan if there are any concerns about obtaining patches or security updates or remaining compatible with ongoing changes (like the ones you are seeing in Java and OS).

  • Sho_Will
    Sho_Will Member Posts: 4 Green Ribbon

    I have attached the error message here above.

  • Sho_Will
    Sho_Will Member Posts: 4 Green Ribbon
  • Michael Ferrante-Oracle
    Michael Ferrante-Oracle Senior Principal Product Manager USMember Posts: 6,627 Employee
    edited June 8

    As I mentioned, you need to upgrade to v12. There are a variety of issues you will experience trying to run newer Java versions with older Forms versions. The first is the fact that the certificates within the Oracle provided jar files in that version have expired. The second issue is that the type certificate used in the Oracle provided jars is no longer supported by newer Java versions.

    Even if you get passed this current issue, likely you will hit others.

    The solution to your issue isn't going to be as simple as flicking a switch. It's time to upgrade. It was time to upgrade about five or six years ago.

Sign In or Register to comment.