Forum Stats

  • 3,734,039 Users
  • 2,246,863 Discussions
  • 7,857,010 Comments

Discussions

error: records are not supported in -source 8

User_ZCIA3
User_ZCIA3 Member Posts: 1 Green Ribbon

https://scans.gradle.com/s/d442mq4icm7qe/console-log?anchor=19

My Gradle build scan

MY Build Gradle below:

plugins {
    id("com.github.johnrengelman.shadow") version "7.0.0"
    id("io.micronaut.application") version "1.5.0"

}






repositories {
    mavenCentral()
}

micronaut {
    runtime("netty")
    testRuntime("junit5")
    processing {
        incremental(true)
        annotations("be.*")
    }
}

dependencies {
    implementation("io.micronaut:micronaut-http-client")
    implementation("io.micronaut:micronaut-runtime")
    runtimeOnly("ch.qos.logback:logback-classic")
    implementation("io.micronaut:micronaut-validation")
    //DGS
    implementation(platform('com.netflix.graphql.dgs:graphql-dgs-platform-dependencies:3.10.2'))
    implementation 'com.netflix.graphql.dgs:graphql-dgs-spring-boot-starter'
    implementation 'com.netflix.graphql.dgs:graphql-dgs-subscriptions-websockets-autoconfigure'
    implementation 'com.fasterxml.jackson.datatype:jackson-datatype-joda'

}


application {
    mainClass.set("be3.Application")
}
java {
    sourceCompatibility = JavaVersion.toVersion("1.8")
    targetCompatibility = JavaVersion.toVersion("1.8")
}




Sign In or Register to comment.