Forum Stats

  • 3,767,978 Users
  • 2,252,735 Discussions
  • 7,874,399 Comments

Discussions

Oracle test manager Cannot get a connection from helper after 120 seconds.

User_7LZXU
User_7LZXU Member Posts: 2 Green Ribbon

Hi Everyone,

Oracle test manager is failing because of the below error while launching a browser

17:27:22,314 ERROR [PlayBackHandler] oracle.oats.scripting.modules.webdom.common.api.exception.BrowserHelperException: Cannot get a connection from helper after 120 seconds.

17:27:24,703 ERROR [1] Error in section Initialize at line (script.java:21). Cannot get a connection from helper after 120 seconds.

this is the below code am using to test to open a browser

import oracle.oats.scripting.modules.basic.api.*;

import oracle.oats.scripting.modules.browser.api.*;

import oracle.oats.scripting.modules.functionalTest.api.*;

import oracle.oats.scripting.modules.utilities.api.*;

import oracle.oats.scripting.modules.utilities.api.sql.*;

import oracle.oats.scripting.modules.utilities.api.xml.*;

import oracle.oats.scripting.modules.utilities.api.file.*;

import oracle.oats.scripting.modules.webdom.api.*;

import oracle.oats.scripting.modules.formsFT.api.*;

import oracle.oats.scripting.modules.applet.api.*;

public class script extends IteratingVUserScript {@ScriptService oracle.oats.scripting.modules.utilities.api.UtilitiesService utilities; @ScriptService oracle.oats.scripting.modules.browser.api.BrowserService browser;@ScriptService oracle.oats.scripting.modules.functionalTest.api.FunctionalTestService ft;@ScriptService oracle.oats.scripting.modules.webdom.api.WebDomService web;@ScriptService oracle.oats.scripting.modules.applet.api.AppletService applet;@ScriptService oracle.oats.scripting.modules.formsFT.api.FormsService forms;

public void initialize() throws Exception { browser.launch();

}

/**

* Add code to be executed each iteration for this virtual user.

*/

public void run() throws Exception {

reportPassed("Hi She"); }

public void finish() throws Exception {

}

}

Below is the screenshot of the OTM result detail

Even if I change the browser in Oracle Load Testing like below

it's trying to launch Launch Browser: InternetExplorer 11.789.19041.0.

Can any one please help me to fix the issu to launch a browser or any set ups am doing wrong