Forum Stats

  • 3,768,176 Users
  • 2,252,755 Discussions
  • 7,874,483 Comments

Discussions

21.2.0.187.1842 No JRE Hangs at Startup--Windows 10

sgeffe
sgeffe Member Posts: 4 Blue Ribbon

Just what it says above..

Running Windows 10 Pro 1809 64-Bit. The version of SQL Developer is in the Subject line. JDK is 1.8.0_281. I'm trying to open Oracle 19c databases.

The output of the "--verbose" command plus the HotSpot dump is attached.

I thought this was supposed to be fixed. Version 20.2 works for me, 20.4 produced the same behavior as this version. If anyone has ideas on how to fix this, I'm all ears!


Tagged:

Answers

  • thatJeffSmith-Oracle
    thatJeffSmith-Oracle Distinguished Product Manager Posts: 8,057 Employee

    Not sure what the issue is, but ...


    Exception in thread "main" java.lang.OutOfMemoryError: unable to create new native thread

  • stom
    stom Member Posts: 105 Bronze Badge

    I faced something similar while trying to open 21.2 on my Windows 10 machine. From the installation notes, I copied the specified DLL file to bin/ and it worked. I had downloaded the "Windows 64-bit with JDK 8 included" version.


    Note: the Windows EXE requires a MSVCR100.dll to run. Most computers will already have this file and in the Windows PATH. However, if the first copy of the file found by the EXE is a 32-bit copy of the DLL, then SQL Developer will fail to start. You can fix this by copying a 64-bit version of the DLL into the BIN directory or updating your OS PATH such that a 64 bit copy of the DLL is found first.

  • sgeffe
    sgeffe Member Posts: 4 Blue Ribbon
    edited Jul 16, 2021 3:54PM

    I tried using the 64-Bit version of the application, but I didn't check that DLL.

    I thought I had tried that workaround previously without success with the 64-Bit version of 20.4, but I'll give that a shot. It's worth a try.