Forum Stats

  • 3,838,691 Users
  • 2,262,394 Discussions


Installation XE 18c not possible

Leo2807 Member Posts: 4 Red Ribbon

Hello @ll,

I try to install XE 18c on my computer (Windows10 Pro) but after a few minutes during the installation a rollback process will be initiate and delete all installation folders completely.

After this rollback there is no any ORACLE folder on my drive.

So it is not possible to have a look on any logs. Only the logfile of Windows Installer with an error code 1603 but this is not helpfully for me in this case ...

Here are my installations points:

- Windows10 Pro

- Run as Administrator

- my windows account belongs to the administration group

- switch off any antivirus tools and firewall during installation

- no oracle folders or systemvariables are noticed

- also tried as silent installation (see oracle doku)

Have you any ideas what happens here and how can I solve this problem ?


  • There's been a few common issues we are seeing, lets make sure you are not hitting them. In particulat pay close attention to #4, #5 and #7 below.

    1) Is ORACLE_HOME or TNS_ADMIN set in the environment? Go to a command prompt, type "set". You will need to temporarily unset any such environment variables.

    2) Are you using Windows 10 Home Edition? It is not supported and the installer is not properly checking for it in the Prerequisite check.

    3) Are you using Server 2019? Same issue.

    4) On your network adapter that you are using, check (enable) "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks".

    5) Check to see if Netbios is enabled on your network connection:

    See this link for more info:

    6) In some cases, antivirus has interfered with an installation. Try disabling anti-virus and then installing.

    7) Try creating a local user and adding to local administrator group and then log in and install as that user.

    If any of these work for you, please report back and let me know.

  • Leo2807
    Leo2807 Member Posts: 4 Red Ribbon


    I saw the same answers and notes in another task and in the past I did all of them - but without a solution of my problem.

    The Link you sent me is faulty and I cannot see the content there.

  • It looks like that link is down right now.

    You can read the instructions in the internet archive:

    One of the main issues with the 18.4 windows installer is that it uses named pipes. This tends to be locked down by anti-virus and by administrators. In future releases of XE on windows, named pipes will not be used.

  • Leo2807
    Leo2807 Member Posts: 4 Red Ribbon

    Thanks you for your help.

    I enabled the NetBIOS with the help in the documentation and start the installation again as Administrator (without any AntivirusTools).

    But it was of no use - I have still the same problem.

  • User_EAI7R
    User_EAI7R Member Posts: 1 Green Ribbon
    edited Aug 23, 2021 1:17PM

    I am also having the same problem, trying a failing to install on 18.4 on 3 PCs. I have successfully installed it on my laptop with no problem but always getting this roll back issue after installation process gets so far on these 3 PCs. I have tried every suggestion I have found with no luck. Is it related somehow to whether or not the PC is connected to a network?

    By deleting all traces of previous attempts to install it, including registry keys, I have now got it to install on 2 of the PCs. I can connect through SQL*Plus but not through the proprietary software I am trying to use there is no Listener service on either PC.