Forum Stats

  • 3,759,066 Users
  • 2,251,495 Discussions
  • 7,870,479 Comments

Discussions

Upgrade application using theme 51

Easydoesit
Easydoesit Member Posts: 25 Blue Ribbon

I want too upgrade from Oracle 11g with APEX 5.1 to Oracle 18c with APEX 21.1.

My standard application give no problems but I have a application using Theme 51.

I tried switching to Theme 42 but that doesn't work.

Is there a way to upgarde my application using theme 5?

Regards Ron Reijgwart

Tagged:

Answers

  • InoL
    InoL Member Posts: 9,272 Gold Crown

    You can still use old themes (I've recently upgraded to 20.2 with an old 2 tab levels custom theme).

    However, at one point you should invest time to move to UT.

  • Easydoesit
    Easydoesit Member Posts: 25 Blue Ribbon

    Thanks for your answer, some old thems can be used. In another application I use Tapaz (4) that works.

    But Theme 51 is a mobile theme and has some Java conflicts and this will BREAK the logon.

  • InoL
    InoL Member Posts: 9,272 Gold Crown

    I didn't upgrade my application with this old theme without any changes in my app. No upgrade works out of the box. Look at all the issues with just the upgrade from 20.2 to 21.1 here on this forum.

    So, from 5.1 to 21.1 you will hit a lot of issues. Both known and unknown. The most important thing to do: go through all release notes of all release between 5.1 and 21.1. You would have noticed:

    7.1.2 Desupport of Mobile Theme - 51 and the jQuery Mobile User Interface

    You might get it to work by including the old libraries in your application.

  • Scott Wesley
    Scott Wesley Member Posts: 6,080 Gold Crown

    I don't think there's any 'might' regarding theme 51 / mobile user interface. I'm pretty sure these apps simply won't work until they're re-engineered.

    Check out the commentary in the UT application

    https://apex.oracle.com/pls/apex/apex_pm/r/ut/migrating-from-jquery-mobile