Forum Stats

  • 3,770,288 Users
  • 2,253,090 Discussions
  • 7,875,388 Comments

Discussions

APEX 20.2 Error on opening public modal dialog in a different application with no session sharing

Toufiq - Hexagon PPM
Toufiq - Hexagon PPM Member Posts: 17 Red Ribbon
edited Aug 26, 2021 3:35PM in APEX Discussions

Hi Devs,

We are on APEX 20.2. When opening a public page modal dialog in a different application (117), we get the below error:

Application 117 Dialog page 2 cannot be rendered successfully. Ensure the page template in use on page 2 is of template type "Dialog page", with appropriate JavaScript dialog initialization, dialog closure and dialog cancel code defined.

Contact your application administrator.

Technical Info (only visible for developers)

  • is_internal_error: true
  • apex_error_code: APEX.DIALOG.PAGE.ERROR
  • component.type: APEX_APPLICATION_PAGES
  • component.id: 117000000002
  • component.name: test
  • error_backtrace:
----- PL/SQL Call Stack -----
  object      line  object
  handle    number  name
000001CC2E2E7658       947  package body APEX_200200.WWV_FLOW_ERROR.INTERNAL_GET_ERROR
000001CC2E2E7658      1015  package body APEX_200200.WWV_FLOW_ERROR.INTERNAL_ADD_ERROR
000001CC2E2E7658      1407  package body APEX_200200.WWV_FLOW_ERROR.RAISE_INTERNAL_ERROR
000001CC32A60D58      1820  package body APEX_200200.WWV_FLOW.CHECK_DIALOG_CS
000001CC32A60D58      2999  package body APEX_200200.WWV_FLOW.SHOW
000001CC32A60D58      5337  package body APEX_200200.WWV_FLOW.RESOLVE_FRIENDLY_URL
000001CC0E42BB50         4  anonymous block


This modal dialog is called from application 114. Both have different Session Cookies.

In application 114, I have a button which calls the modal dialog (Redirect to a page in different application) in 117 which is public (Authentication = Page is Public).

However, I tested the same in APEX 21.1 (apex.oracle.com) modal dialog opens without issue.

Is this a known issue in APEX 20.2 and is fixed in 21.1?

If yes, any workaround to open public modal dialog pages from different applications.


Thanks

--Toufiq

Tagged:

Answers

  • Jon Finke
    Jon Finke Member Posts: 62 Bronze Badge

    I will comment that I received the same error message from APEX 21.1 - (although I was sharing session cookies). But when I switched from friendly URLs to traditional URLs (Legacy URLs? Hostile URLs?) it worked. Note - app is still set for friendly URLs, I just generated the old kind and that worked.

    This is triggered from a button located in a Card report.