Forum Stats

  • 3,767,857 Users
  • 2,252,726 Discussions
  • 7,874,366 Comments

Discussions

Cannot add System filesystem

calinm
calinm Member Posts: 76 Blue Ribbon

Hi,


I get the error below when I try to start sqldeveloper.exe on a windows 2019 server. Any ideas?


ava.lang.NullPointerException

       at org.netbeans.core.startup.layers.SystemFileSystem.createInstallHomeSystem(SystemFileSystem.java:278)

       at org.netbeans.core.startup.layers.SystemFileSystem.create(SystemFileSystem.java:240)

       at org.netbeans.core.startup.layers.SessionManager.create(SessionManager.java:99)

       at org.netbeans.core.startup.NbRepository.createDefaultFileSystem(NbRepository.java:155)

       at org.netbeans.core.startup.NbRepository.<init>(NbRepository.java:79)

       at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

       at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)

       at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)

       at java.lang.reflect.Constructor.newInstance(Constructor.java:526)

       at java.lang.Class.newInstance(Class.java:374)

       at org.openide.util.lookup.implspi.SharedClassObjectBridge.newInstance(SharedClassObjectBridge.java:64)

       at org.openide.util.lookup.MetaInfServicesLookup$P.getInstance(MetaInfServicesLookup.java:496)

       at org.openide.util.lookup.AbstractLookup.lookup(AbstractLookup.java:422)

       at org.openide.util.lookup.ProxyLookup.lookup(ProxyLookup.java:223)

       at org.openide.filesystems.Repository.getDefault(Repository.java:362)

       at org.netbeans.core.startup.Main.start(Main.java:306)

       at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)

       at java.lang.Thread.run(Thread.java:745)

Cannot add System filesystem, exiting...

When I try the bat file, I get:


E:\APPS\sqldeveloper\sqldeveloper\bin>..\..\jdk\bin\java -Xmx640M -Xms128M -Xverify:none -Doracle.ide.util.AddinPolicyUtils.OVERRIDE_FLAG=true -Dsun.java2d.ddoffscreen=false -Dwindows.shell.font.languages= -XX:MaxPermSize=128M -Dide.AssertTracingDisabled=true -Doracle.ide.util.AddinPolicyUtils.OVERRIDE_FLAG=true -Djava.util.logging.config.file=logging.conf -Dsqldev.debug=false -Dide.conf="./sqldeveloper.conf" -Dide.startingcwd="." -Dide.pref.dir.base=H:/ -Dide.work.dir.base=H:/ -classpath ../../ide/lib/ide-boot.jar oracle.ide.boot.Launcher

ERROR: You're trying to run the product with the legacy launcher oracle.ide.boot.Launcher . Check your <product>.conf file and be sure to include:

       AddJavaLibFile ../../ide/lib/fcpboot.jar

       SetMainClass   oracle.ide.osgi.boot.OracleIdeLauncher

I did try adding fcpboot.jar, but the error persists.


Thanks!

Answers