Forum Stats

  • 3,768,925 Users
  • 2,252,875 Discussions
  • 7,874,802 Comments

Discussions

SQL Developer Data Modeler: Import from Oracle Designer: 'Select Objects to Import' list is empty

Hi all,

our customer is using Oracle Designer 9i (current version 9.0.2.92.9). Designer repository stored in Oracle 9i Enterprise Edition release 9.2.0.4.0. They want to import their workareas to Oracle SQL Developer Data Modeler. We are trying with Data Modeler 21.2.

In the Oracle Designer Import Wizard: we manage to connect to Oracle Designer repository, and we get the whole list of Workareas displayed. We are able to select one, and then we get the full list of Application Systems displayed (Workarea, Application System, and Branch).

At this step, whatever we select, when we press the "Next" button, we get the same behavior: a little pop-up window headed "Error" displaying a big red X with no error message provided. We press "OK", and if we press again "Next", we get to step 4 (Select Objects to Import) which is empty. Therefore, in step 5 (Generate Design), the "DB Objects that will be imported" list is empty, so the design is generated, but it is empty.

As attached, the datamodeler.conf file.


Any ideas about this? Many thanks in advance

Silvia

Answers

  • Philip Stoyanov-Oracle
    Philip Stoyanov-Oracle Member Posts: 3,352 Employee

    Hi Silvia,


    can you look for errors in the log file it's in menu "View>External Log"?

    Another point - Oracle 9 probably is not supported well by JDBC driver shipped with DM 21.2. It'll be better to try with older version of DM.

    Philip

  • SCapra-Oracle
    SCapra-Oracle Member Posts: 2 Employee

    Hi Philip,

    please find attached the log files, both for version 21.2 and 17.2. By using 21.2 at least we can see the list of workareas and application systems. Instead with 17.2 the list of work areas is not displayed. I was allowed to select one random workarea: a list of blank application systems was displayed, again I selected one random and tried.

    We could not find any older version of DM in OTN downloads: 19.4 is the oldest available. We also tried with versions 20.x and 19.x, but empty logs are provided. Is there a way to find older versions?

    Thanks again

    Silvia