Forum Stats

  • 3,768,286 Users
  • 2,252,771 Discussions
  • 7,874,515 Comments

Discussions

What’s the Oracle developer tool version support for Oracle database 19c

I have a query, I’m trying to connect Oracle database 19c with Visual studio 2015 and Oracle developer tool version 12.2.1200 using Entity framework.


My Entity framework wizard is crashing, so I want to know which ODT version should I have to install, which will support Visual studio 2015 and Oracle 19c also.

Answers

  • Christian.Shay -Oracle
    Christian.Shay -Oracle Posts: 1,965 Employee
    edited Nov 22, 2021 7:26PM

    When you say it is "crashing" can you describe exactly what is happening and provide any error numbers you get?

    The version of ODT you are using will work with VS 2015, however Entity Framework is very sensitive to the version of ODP.NET that is used. It may not be possible to use this version of ODT with the newer versions of EF because ODT uses ODP.NET 12.2.

    If you need to use newer versions of Entity Framework, you should upgrade to Visual Studio 2019 (and ODP.NET 19+ and ODT 19).