Forum Stats

  • 3,767,978 Users
  • 2,252,735 Discussions
  • 7,874,399 Comments

Discussions

Access denied to procedure named: f

Hi everyone,

we are responsible for the operating more than 100 APEX Stacks. All stacks are build up almost identically. The stacks consists of a Loadbalancer, an Application-Servers running Apache and Tomcat with ORDS (Version 20.3 and 21.2) and a database (19c with APEX 20.2) running on a different server.

In the last 2-3 months we've started encountering a strange bug, which we neither could explain nor reproduce. From time to time it happens out of the blue that the ORDS starts responsing with the following error:

403: Access to the procedure named: f is denied.

From this time on every call to this Server returns the same error.

There is nothing exceptional in the logs. Calls to REST-Services still work.

The only solution in this case is to restart Tomcat. After that the error is gone and everything is fine again.

The error occurred only on about 5 of the stacks we are running, but none of them are different in any kind. Upgrading the ORDS-Version didn't help.

Also even we tried a lot of things, we could not reproduce the error in any way.

Does anyone have an idea about that or how to track it down.

Thanks a lot in advance!

Rudolf

Tagged:

Answers