Forum Stats

  • 3,767,978 Users
  • 2,252,735 Discussions
  • 7,874,399 Comments

Discussions

Installation Oracle 21c XE

Hello

My name is Michelle.

I have problems to install Oracle version 21c xe

I have installed on Windows 10, but I'm getting an error to connect database on SQL Developer.

The error is below:

I checked the database as Sysdba and it looks ok:

Also, I check the listener status and looks ok:


Does anyone have an advise on how to fix that?

Answers

  • L. Fernigrini
    L. Fernigrini Data Engineer Sr Consultant Member Posts: 3,664 Silver Crown

    You need to make a couple of changes to the connection on SQL Developer

    1) Switch the radio set from "SID" to "Service Name" (Nome do Servico in Portuguese)

    2) Use XE or XEPDB1 as service name to connect to the CDB or to the PDB that is created automatically with XE.

  • L. Fernigrini
    L. Fernigrini Data Engineer Sr Consultant Member Posts: 3,664 Silver Crown

    You can run "lsnrctl services" to check all services that the listener is giving access, post the result (as text rather than image) if you still have issues connecting.

  • Torsten Kleiber
    Torsten Kleiber Member Posts: 182 Bronze Badge

    Seems that you have no instances of services xe, xexdb and xepdb1. If you look into windows services, I believe you will not find OracleServiceXE. In my opinion this happens, when dbca does not create the database successfully. This ist the sub window in manual installation process.

    This happens here too on our enterprise laptops and I cannot find out why.

    Unfortunatly there is no support for xe, so I don't know how to find somebody to deep dive into the installation logs to find the root cause. Can anybody help with this?

    So long we further using 18c XE.

  • Christian.Shay -Oracle
    Christian.Shay -Oracle Posts: 1,965 Employee
    edited Nov 12, 2021 5:16PM

    As Torsten Kleiber said, you don't show any services running when you issue lsnrcrl status. I assume you are showing us the complete results of that command?

    Check to see if you see OracleServiceXE service in the services and if it is stopped, start it. If it doesn't exist, deinstall and reinstall XE.

  • Michelle and Torsten,

    Can you please zip up the contents of the [Oracle_Base]\cfgtoollogs\dbca directory and email them to me at christian dot shay at oracle dot com? I will look at your logs and see if I can figure out what is happening.

    For example: c:\app\username\product\21c\cfgtoollogs\dbca

    Then post here to let me know you emailed it?

  • Michelle Kramm
    Michelle Kramm Member Posts: 18 Green Ribbon

    Hey guys

    Thank you for being able to help with this.

    Well I tried to login on SQL developer with IP show in host protocol instead of only localhost and it worked.. After days trying to figure it out.


  • Torsten Kleiber
    Torsten Kleiber Member Posts: 182 Bronze Badge
    edited Nov 13, 2021 12:01PM

    @Christian.Shay -Oracle:

    At the moment I had deinstalled XE 21c and installed XE 18c again. For further testing had now deinstalled XE 18c. Now I cannot install XE 21c anymore on both test machines.

    Silent installation says "MainEngineThread is returning 1603", which means that XE 21c is already installed, which it is not.

    Silent deinstallation says "MainEngineThread is returning 1605", which means that the program, which should be uninstalled, is not installed.

    So, I cannot create an test case anymore. I have sent you the install and uninstall log, maybe you have an idea, why this happens?