Forum Stats

  • 3,767,978 Users
  • 2,252,735 Discussions
  • 7,874,399 Comments

Discussions

Sql Developer almost instantly crashes on Mac OS Monterey

User_VYN58
User_VYN58 Member Posts: 1 Green Ribbon

So I installed Sql Developer(version: 21.2.1) for Mac OS Monterey. No problems here. From https://www.oracle.com/tools/downloads/sqldev-downloads.html I know that I need JDK version 8 or 11. I tried both but I stil can't work with Sql Developer. When I click Sql Developer icon I see loading screen, then the main window but after a couple of seconds the app closes and a new window pops out with this message(actually there is more thread-like messages).

User ID:               501

Date/Time:             2021-11-14 13:12:19.2730 +0100
OS Version:            macOS 12.0.1 (21A559)
Report Version:        12
Anonymous UUID:        42C17E3D-C7E1-9FAC-5295-1E81AB3069AF

Sleep/Wake UUID:       5AB9D3A9-910B-47AB-9BF2-ED672A3D5267

Time Awake Since Boot: 90000 seconds
Time Since Wake:       5059 seconds

System Integrity Protection: enabled

Crashed Thread:        48  Java: Thread-18

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
abort() called

Thread 0:: AppKit Thread Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib              0x7ff81fd57aba mach_msg_trap + 10
1   libsystem_kernel.dylib              0x7ff81fd57e2b mach_msg + 59
2   CoreFoundation                      0x7ff81fe5ba42 __CFRunLoopServiceMachPort +     319
3   CoreFoundation                      0x7ff81fe5a11b __CFRunLoopRun + 1325
4   CoreFoundation                      0x7ff81fe5952d CFRunLoopRunSpecific + 563
5   HIToolbox                           0x7ff828a773e1 RunCurrentEventLoopInMode + 292
6   HIToolbox                           0x7ff828a77137 ReceiveNextEventCommon + 587
7   HIToolbox                           0x7ff828a76ed5     _BlockUntilNextEventMatchingListInModeWithFilter + 70
8   AppKit                              0x7ff8228848f0 _DPSNextEvent + 886
9   AppKit                              0x7ff822882f5c -[NSApplication(NSEvent) 

I can't figure it out on my own. As I said, I tried running Sql Developer with JDK version 8 and 11. I specified which version Sql Developer should use by adding SetJavaHome /Library/Java/JavaVirtualMachines/jdk1.8.0_311.jdk/Contents/Home in product.conf file.

Do you know what I am missing here? Thanks in advance!

PS: I can provide more information If you want!

«1

Answers