Forum Stats

  • 3,855,697 Users
  • 2,264,546 Discussions
  • 7,906,142 Comments

Discussions

Oracle XE 21c - Installation Error {IDS_OracleConfigDlg_DatabaseConfigFailedMsg} ORA-12560

Hi folks

I am on Windows 10 and trying to install Oracle XE 21c

I downloaded the install here: https://www.oracle.com/ca-en/database/technologies/xe-downloads.html

I went through the installation with all the defaults and no issues up until this step

I got hit with the following error

{IDS_OracleConfigDlg_DatabaseConfigFailedMsg} An error occured while configuring Oracle XE database. Check the logs at C:\app\user\product\21c\cfgtoollogs\dbca and try again

I clicked on "Retry" but got hit with the same error. Then I went to "Abort" and the installation appeared to complete.

I did a quick tnsping and see the following

I thought great - Ok maybe its just an error but things are up and running.

When I try to connect via the newly installed SQL Plus I hit the following error

Weird ok, I then try to connect via SQL developer and see the following error

Status : Failure -Test failed: Listener refused the connection with the following error:

ORA-12505, TNS:listener does not currently know of SID given in connect descriptor

 (CONNECTION_ID=xtAG2YGQTYCEiT634/dAvg==)

Alright well this sucks, I went to the previously suggested logs when I initially hit the error here:

C:\app\user\product\21c\cfgtoollogs\dbca

And I then see the following 4 log files

The contents of the log file are pretty big so I wont post it here

But does anyone know what could be wrong? I was really hoping to install Oracle XE to re-immerse myself in the Oracle database ecosystem for an upcoming project.

Any advice much appreciated

«1

Answers

  • chillychin
    chillychin Member Posts: 258 Bronze Badge

    I also forgot to mention I currently have an Oracle 19c client installed on my machine - No other databases, just the client so I would assume this would not have any impact?

  • If you are still having the problem, the answer will be in those logs. You can try emailing them to me and I can take a look christian dot shay at oracle dot com.

  • chillychin
    chillychin Member Posts: 258 Bronze Badge

    Hi Christian

    Thanks for following up

    I sorta figured out loosely what the problem may have been

    I was trying to install this on my work PC - Which I am able to install other applications, so assumed that I should have admin rights.

    I tried to run the installer as "an admin" and it gave me an error saying unable to proceed (cant remember exact wording).

    I did some digging and found some suggestions that if I am working remotely to log in to my work VPN so it can validate that I have admin rights.

    I logged into my VPN and the initial error went away and I was able to install up until I hit the error.

    I tried installing Oracle then on my personal laptop (was avoiding it since my laptop is from 2010) - And voila it worked without a problem.

    So I strongly suspect that even though intially it complained that I wasnt an admin and it appeared that I rectified it, something else was probably not working.

    Hope if anyone else comes across this thread they can see if they are in a similar situation

  • User_VBLQB
    User_VBLQB Member Posts: 1 Green Ribbon

    I have the same error, did you find a solution?

  • chillychin
    chillychin Member Posts: 258 Bronze Badge

    When I first tried to install Oracle XE it was on my company laptop - Even though I chose to run the .exe as a "Run as Adminstrator" and it didnt give an error during initial install, it did end up with the error as I noted.

    I was able to install it on my personal laptop - Which I have full admin access to and it installed smooth as butter.

    I suspect there's something else that may be missing in my company laptop permissions to allow me to fully install the exe.

    You could maybe talk to your company admin (if your installing on your company laptop) to see if they can install it for you.

  • User_X9QH3
    User_X9QH3 Member Posts: 2 Green Ribbon

    I have the same error, did you find a solution?

  • User_JLXED
    User_JLXED Member Posts: 2 Red Ribbon

    There is a known issue that continues to exist from Oracle 19c XE with the current Oracle 21c XE

    Check for a few more log files, particularly in the ..\cfgtoollogs\dbca\XE folder. There will be a trace.log_YYYY_MM_DD_HH_MI_SSxM file. You may find this error item within it:

    DIM-00019: create service error

    O/S-Error: (OS 1053) The service did not respond to the start or control request in a timely fashion.

    Check the length of the hostname of you machine. Is it greater than 15 characters? If it is, rename to less than 15 characters. Then, remove the Oracle XE 21c software by re-running the installer, reboot and install again.

  • User_CXOTY
    User_CXOTY Member Posts: 2 Green Ribbon

    I have the same error, did you find a solution? TT

  • User_7VXFN
    User_7VXFN Member Posts: 1 Green Ribbon

    I have the same error, any one please send the solution.

  • Christian.Shay -Oracle
    Christian.Shay -Oracle Posts: 2,201 Employee
    edited Sep 14, 2022 2:44PM

    Hello,

    There is a bug in Oracle Database on Windows with machine name (Device name) greater than 16 characters. I will be posting a sticky to this forum about the issue soon.

    If you see this error:

    "O/S-Error: (OS 1053) The service did not respond to the start or control request in a timely fashion."

    Try changing your machine name/device name to 16 characters or less and then restart your machine and try to reinstall.

    User_EQTO3User_VFRN0