Forum Stats

  • 3,837,410 Users
  • 2,262,256 Discussions
  • 7,900,273 Comments

Discussions

SQL Developer 21.4.2 compatible with Java SE 17?

User_89UW5
User_89UW5 Member Posts: 3 Green Ribbon

Is SQL Developer 21.4.2 compatible with Java SE 17?

Best Answer

  • Philipp Salvisberg
    Philipp Salvisberg Member Posts: 181 Silver Badge
    edited Feb 24, 2022 10:52PM Answer ✓

    No. You get a warning during start. Most of the things work. However, all GUIs using JavaFX will not. It's not part of the JDK anymore. You have to hack around it to make it work.

    Use JDK8 or JDK11 for the time being. That's supported.

Answers