Forum Stats

  • 3,815,381 Users
  • 2,259,010 Discussions
  • 7,893,063 Comments

Discussions

How do you install and configure customer managed ORDS on Autonomous Database?

Has anyone been able to successfully install and configure Customer Managed ORDS on Autonomous Database? I have been trying to follow the documentation but can't seem to start ORDS. My customer managed environment for ORDS runs in Oracle Cloud Infrastructure (Oracle Linux 8.5). I have followed it up to the step "/opt/oracle/ords start" but then get the error "-bash: /opt/oracle/ords: Is a directory". I also tried to follow this tutorial but when I ran the command "sudo systemctl start ords" I get an error: "Job for ords.service failed because the control process exited with error code. See "systemctl status ords.service" and "journalctl -xe" for details.". Has anyone been able to successfully set this up and if so, can you provide the link or explain the steps you used to do so?

Answers

  • Mike Kutz
    Mike Kutz Member Posts: 6,181 Silver Crown

    I'm just following this post.

    I'm on Free Tier. But, it looks like I need "Customer Managed" for some of the features.

  • jariola
    jariola Member Posts: 10,735 Silver Crown

    If you have installed ORDS using yum following blog post you mention, run

    systemctl restart ords.service
    systemctl status ords.service
    

    Last command should give some information what could be problem

  • User_GYA7R
    User_GYA7R Member Posts: 2 Green Ribbon

    Thanks @jariola for your response. When I ran the last command this is what I got:

     ords.service - Oracle REST Data Services

      Loaded: loaded (/etc/systemd/system/ords.service; enabled; vendor preset: disabled)

      Active: activating (auto-restart) (Result: exit-code) since Fri 2022-03-18 21:45:00 GMT; 38s ago

     Process: 1463918 ExecStart=/usr/bin/bash -c /etc/init.d/ords start (code=exited, status=1/FAILURE)

     Main PID: 979939 (code=exited, status=1/FAILURE)


    Any thoughts on what the suggested problem is?

  • tossbrink
    tossbrink Member Posts: 1 Green Ribbon

    Problem with Oracle Linux 8.5 try with oracle linux developer image or ol7_oci_included.