Forum Stats

  • 3,875,575 Users
  • 2,266,950 Discussions
  • 7,912,258 Comments

Discussions

JCE cannot authenticate the provider (WebSphere (8.5.5.18, IBM java 191)

User_381UP
User_381UP Member Posts: 1 Green Ribbon

Hello Java Community,

We got our first JCE code-signing certificate from Oracle in 2018.

One of our client has the following problem:

they need to run the JCE provider on WebSphere (8.5.5.18, IBM java 191), which does not accept this certificate and return JCE authenticaton error (java.lang.SecurityException: JCE cannot authenticate the provider).

Our tests show that newer version of the appserver WebSphere 9.0.0.11 accepts the certificate, but for our client upgrading is not an option.

Can we get a code-signing certificate with an older issuer somehow, that may be possibly accepted by WebSphere (8.5.5.18, IBM java 191)?

Answers